Flashed tp-link 1043nd v1 with trunk (ath79) and can't connect

I built a trunk with LTE modem support. The router boots OK and modem connects according to it's LED.
But I can't connect to the router even in failsafe mode. Telnet fails with "no route to host".
The device is not bricked, but something is wrong. Is it possible to fixed without soldering?

1 Like

Try ssh -- tenlet hasn't been supplied or supported by OpenWRT/LEDE for a while now.

1 Like

I tried ssh with the same result. Something is broken there. The device is not totally bricked, since it connects to modem. But it seems that there is no way to reach it. I can't solder UART, so it seems that I need a new device.

I expected that trunk won't work, but not to this extent. Failsafe should work.

I need to mention that I built with ath79. That was the point to test if it gives any improvement to this old device.

1 Like

Went from ar71xx to ath79? Might want to check with the ath79 thread -- I vaguely remember that new config might be required. Have you tried 192.168.1.1?

The ath79 builds for this device did have a problem with the switch.
Dont't know what exactly...

Search in this thread for some statements of @lucize

yeah, V1 is a bummer at the moment, using initramfs it will work no matter what, as soon as you flash it on the device it will depend on the planet alignment.

I brought the device to failsafe state with SYS blinking fast. But I can't connect to it.

it's a driver problem, it won't work, only tft recovery, and I think that I didn't activated the wifi button so you can't connect to it by wifi either, sorry

1 Like

I got the UART and I will recover the device soon. What needs to be done in dts to get it work?

I think is not a dts problem, it is working alright if you bootm a initramfs image, but as soon as you flash it to the device it will not work anymore (the switch part), and rfkill is not set to qss button, so no wifi either if you press the button to connect to it by wifi. there is traffic on switch ports if you do tcpdump but I don't understand what is the problem

This device has only one eth0 port. The wan and lan interfaces are split only by VLAN.
Maybe you didn't set one port as tagged to be able to connect to CPU. I am trying to figure this out in the source.

look into the pr or /etc/board.d/02_network, is how it is supposed to be, I tried without vlan but I repeat, if you ramboot the image it will work, sometimes the flashed image will work too, but very rarely

What do you mean by "rarely"? On the same device?

Same device, same image, after power unplugged, didn't figured out why.
Usually when is not working, link on port 4 is up after a while, when is working, the link is up as it should

Oh, that is a real mystery. I'll unbrick it next week and will have a chance to play with it. Maybe something useful in UART will be seen.

And it is working. I flashed with the same settings and I see that it brings up a USB modem that I had settings for.

This means that while flashing or first boot some relative params are calculated and written. But the CPU is not fast enough to do the job, or some time is just...
It is tricky to debug it. I don't have enough knowledge on that code.

Hi, I have not read the whole discussion, but I've seen LTE modems with ip 192.168.1.1, which conflicts with default openwrt's. Have you tried to set your openwrt to different ip range (i.e. 192.168.11.1)? You will have to do this prior connecting the lte modem.