Flashed OpenWrt onto DWR-9121 (C3) - no internet connectivity?

I have a D-Link DWR-921 Revision C3. (Australia)

Previously, this was running the stock D-Link firmware from here (DWR-921C3 FW1.01.3.014):

http://support.dlink.com.au/Download/download.aspx?product=DWR-921&revision=REV_C&filetype=Firmware

I saw the wiki page here:

https://openwrt.org/toh/d-link/d-link_dwr-921

and downloaded the latest OpenWRT build for this unit:

http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7620/openwrt-19.07.4-ramips-mt7620-dlink_dwr-921-c3-squashfs-factory.bin

I was able to flash this onto the DWR-921 C3, and it boots up successfully into OpenWRT.

However, there doesn't appear to actually be any internet connectivity?

If I SSH in, and try to ping 8.8.8.8, it times out.

When I check the web interface, it lists the model as the C1, not the C3 - is that expected behaviour?

Also, there doesn't appear to be any working LTE connection under networks:

Here is the kernel log (dmesg):

And the system log:

Is there some trick needed to get the LTE modem working on this model with OpenWRT?

Or something I've missed in the above?

1 Like

Aha, I found the instructions further down here:

I SSH-ed in, and tried entering them:

root@OpenWrt:~# uci set network.wwan=interface
root@OpenWrt:~# uci set network.wwan.proto='wwan'
root@OpenWrt:~# uci set network.wwan.apn='SANITISED'
root@OpenWrt:~# uci set network.wwan.pincode='SANITISED'
root@OpenWrt:~# uci set network.wwan.auto='0'
root@OpenWrt:~# uci commit network
root@OpenWrt:~# uci set firewall.@zone[1].network='wan wwan wan6'
root@OpenWrt:~# uci commit firewall

(Out of curiosity - why is the PIN code required here? I don't believe I needed it on the stock D-Link hardware, it just picked up the LTE connection automatically. Just curious.)

I then rebooted the router, and then entered in the commands:

ifup wwan

I now have a working LTE internet connection!

To clarify - do I need do use the ifup command every single time I boot up the router? Is there a way to have it start automatically?

And in the Luci Web UI, it says:

Unsupported protocol type.

When I click on install, it tries to search for a "luci-proto", then returns:

No packages matching "luci-proto". (Reset)

Is this related to the alternative instructions here:

Is there any disadvantage to that approach (using QMI etc.) versus the first approach?

Exactly the same over here.

First of all, /proc/cpuinfo is showing

MIPS: machine is D-Link DWR-921 C1

but the label on the back of the hardware is showing C3 - and the software was built for C3 and is running fine.
Somehow this is confusing... (I need to open the case to check what is really inside)

Also,

ifup wwan

is required after restart.

Cheers, Frood

Hi all!

First of all I must note that I am not a professional at Linux matter.
I was using D-Link DWR-921 rev C3 for some time. I had a big issue with WiFi connection to laptop (actually two laptops). The connection was dropping (No internet, secured). Only solution was restart of the router and the laptop. I have tried lots of solutions and couldn't find any.

So when I found that there's a compatible build of OpenWRT I have flashed it. As I said I'm a noob, so I couldn't get it working with LTE connection. I found a tutorial here:
https://teklager.se/en/knowledge-base/openwrt-4g-wwan-configuration/
So I tried to download package qmi-utils, but had no internet access. I only had WiFi hotspot from my smartphone. Now I know I just could connect directly from router GUI to my WiFi, but instead I downloaded the package from OpenWRT web page. It couldn't be installed because missing dependencies. So I was downloading all those packages one by one :man_facepalming:
If any one want to know, all are here:
https://downloads.openwrt.org/releases/19.07.3/packages/mipsel_24kc/
After some issues I had a working LTE connection. Next I had some problem with enabling WiFi. Instead of attaching lan I was attaching WAN which seemed logical to me.
Now the router is working, uptime is:

The WiFi issue is gone! :smiley:

So anyone trying to get this router working with OpenWRT just follow steps from tutorial I used.

Now I have some questions: as I am paranoid of updating everything, I have updated all of the available packages updates. Later I found somewhere that I shouldn't do that. Is it true? Do you think I should re flash the firmware? The router seems to be working fine.
Only thing I found that the internet speed is looking to be slower than on stock firmware. But it is LTE so I must do more tests.

I can confirm that OpenWRT sees it as C1 revision. Feel free to ask me anything, and thank you.
Cheers.

Just updated this router to newest version (21.02.0), and it's still working :slight_smile: