Flashed NOR instead of NAND image on Mikrotik hEX lite RB750r2


So, I did a rather stupid thing....Hope someone can help me with this?
I wanted to update the OpenWrt firmware on this router, and I chose the wrong firmware file.
I was supposed to use this firmware http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/mikrotik/openwrt-18.06.2-ar71xx-mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin
but I made a mistake and selected this http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/mikrotik/openwrt-18.06.2-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin
The router already had a previous version of OpenWrt on it, and was working.
I did the update through Luci.
Now there's no connectivity on the ports.
Is it bricked or is there way to recover it?
Please advise.


I also have this problem...

This looks promising,


I tried that.
Netinstall does detect the device but does not install RouterOS
No connectivity on LED's. Only Power and USR LED comes on.

I manged to fix it, followed the instructions again from below

Netinstall didn't work, but following the procedure to install OpenWrt again worked.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.