Flash OpenWrt for Linksys RE6500/RE6500HG

Hello everyone, I'm having trouble flashing my Linksys RE6500, I've followed all the methods in the forum but it still doesn't work. I have done TFTP method also still no results. Can you help me solve this problem? Thank you very much.

@ColtonYYZ can you help me sir, please.

Can you provide the steps you are doing? Tell me what's happening.


  1. Download initramfs-kernel.bin and sysupgrade.bin as shown above

  2. Set up a TFTP server. Have it host the initramfs file but rename it to um_factory_fw.bin

  3. There won't be time to do a DHCP exchange so configure the TFTP server (or the host running the server) to have a address on a subnet.

  4. Connect with an ethernet cable and power the RE6500 on.

Until this step nothing happened.

I think, there is an error setting on Tftpd64? Can you help setting through Team Viewer? Or is there a special method for installing OpenWRT on Linksys RE6500? Can you explain step by step to make it easier.

Sorry for the delay in replying... I can help you. I sent you a pm and have waited to see if you would reply but haven't heard back. Are you still needing help? Shoot me a pm with your Teamviewer ID.

@ColtonYYZ Sure wait bro🙂

Im already sent TV ID.

FYI my Linksys firmware version : Ver.