Flash OpenWrt 18.06.1 to WRT1200AC failed[Solved]

I have followed the steps described on wiki https://openwrt.org/toh/linksys/wrt_ac_series#openwrt_oem.

1.Download 18.06.1 factory image.
2. Manual upgrade on router's web with the image.
3. It will reboot and fall back to OEM firmware.

Does any one have this problem? How to solve it?

WRT 1200AC have 2 partitions. make sure to upgrade the both partitions.

After a primary image flash, bootloader will detect an error and boot to the alternative image. witch is still with the OEM firmware.

how can I flash two partition on web management pageļ¼Ÿ

Check the validity of the image you downloaded, a good image should work fine. The device will switch partitions after 3 failed boot attempts. Flashing an image that has an issue to both partitions seems to be a good way to defeat the fail-safe feature of having two partition.

via the web management page you can't.

You can just flash the current running image.

I have checked the image with sha256sum, the result has pass the validation.

However after I flash the factory.img it still not working.
I guess there might be a problem on 18.06.1 release.
With some tries on 18.06.0, it also failed.

I think this is probably a one-off, otherwise there would be a lot of raised voices. There are some threads here regarding known issue(s) with the caiman (memory or heat issue iirc). If you are sure the image is flashing (and rebooting a total of 4 times on the boot failure), I think you will need a serial connection to see if you can spot the issue.

Both 18.06.0 and 18.06.1 flashed fine from Linksys stock on my wrt1200 v1 fwiw, so I think @anomeome is right that it's probably a specific problem to your device.

Quick FYI, the link posted should be OEM >> OpenWrt

Are you flashing via ethernet, and not WiFi, and you are using the system img, not sysupgrade bin? If so, you'll need to connect via serial to diagnose what's going wrong in the boot process, as the flashed partition is refusing to boot, kicking it back over to the previous partition.

  • You can also then flash via serial, but I'd be curious what the serial output is showing when it tries to boot the flashed partition.

Have you tried to manually switch partitions via the power switch? That would determine if it's a flashing error or whether it's an issue with the OEM firmware not properly switching to the flashed partition upon reboot.

Flashing occurs via a round robin:

  • Partition 1 booted: Partition 2 flashed, Partition 2 boots
  • Partition 2 booted: Partition 1 flashed, Partition 1 boots

Thank you for all your help. I have fixed the problem after I flash the openers image with a manual switching to alternative partition(the three times reboot).
I do not know if it is a common case on wrt1200. it's best to add the instruction into the wiki for new starter. may be someone have permission should do.

@Yindong If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Please elaborate, as I'm not understanding what you're asking to have added to the wiki. How to recover the firmware is already in the wiki... Of which I linked to in my prior post.

I mean the guideline about how to use the image on new brought WRT1200AC. on wiki it just said how to flash without following the switch partition instructions.

What specifically are you referring to?

There's no reason to swap partitions manually when flashing firmware, as is mentioned in the wiki, flashing occurs via a round-robin.

Your issues were not a result of the wiki flash steps, but of a corrupted firmware flash, ether from not verifying the checksum of the image before flashing (warning is in the wiki), flashing via WiFi (warning is also in the wiki), perhaps closing the browser window before the flashing process completed, etc.

  • You chose not to troubleshoot your issue by not accessing your router via a serial connection to determine what's causing the issue during the boot process...
    • There's a reason the second bullet at the very top of the WRT AC Series ToH's Introduction recommends users have access to a USB-TTL cable or USB-to-UART prior to flashing 3rd party firmware.
      • Time and again, users refuse to heed this recommendation, even though it's the only way to troubleshoot boot issues.