Flash gone wrong on EdgerouterX

Thanks, that worked. Where do I go from here? I can confirm I see the openwrt logo when ssh into root, but I still cannot access in a browser. I tried different browsers and clearing cache. Where do I go from here? Is the flash of the firmware complete, or should I still follow the guide from Factory firmware installation method (https://openwrt.org/toh/ubiquiti/edgerouter_x_er-x_ka)? I am wired from ETH1 to PC.

netstat -plutn, would list services running on the router. if there is port 80 or 443 listed then it should be viewable on a workstation web-browser otherwise it wasn't installed as part of the original firmware. If space permits you should be able to install luci (the web interface) after updating the opkg feeds.

document link is over here for installing luci,

1 Like

Welp, I think it's bricked now. I did a sysupgrade -f with openwrt-22.03.5-ramips-mt7621-ubnt_edgerouter-x-squashfs-sysupgrade and now it wont ping from any ETH port. Trying to ssh in just returns ssh: connect to host port 22: Unknown error

Thanks for all that tried to help!

Edit: Never mind, it's pinging again, but still can't login with port 22: unkown error

Try the web interface now, as you have installed a release build which includes it.

If you upgrade from a swconfig to a dsa build you also needed -n to make it rebuild the config files in DSA format, or Ethernet will be inaccessible. In that case though it wouldn't ping either.

If you have serial that can be used to investigate and likely quickly fix by running firstboot. Without serial you'll have to go through the whole debrick process of TFTP in the special recovery stock firmware, then repeat the install process completely.

Actually, if OpenWrt is running you can rebuild config files with the reset button. Give it time to boot up fully then press and hold the button for 10 seconds and release. All the lights should blink and it reboots to defaults.

I already tried forcing it into TFTP to start fresh, but the lights don't respond to a 30 sec pin reset. I just tried it again and nothing happens. I did see the OpenWrt logo when logging in early, so unsure why it won't work. I think the .bin I flashed might of messed it up.

I somehow recovered it and got the stock firmware working :grinning:

I'm going to try starting over fresh using the official guide.

"Server interface" needs to be your Ethernet port (set with a/24 static IP such as

On many Ubiquiti the recovery TFTP stops listening after about 30 seconds, even though the lights continue to flash. You would need to start it again.

the initramfs image is meant to be running only from volatile flash, so it makes sense that if you reboot the system the box will revert to stock.
ssh root@ -- is for openwrt (there is no ubnt user for openwrt)

..fwiw if there is no luci-web interface installed, you probably can use "sftp or scp" to upload the sysupgrade image to the box.

1 Like

I'm back to bricked and can't recover, keeps giving me PUT Access Denied or access error.


How I tried

  1. ETH0 to PC
  2. I manually setting ip: / / confirmed assigned with ipconfig /all
  3. I manually hard reset router
  4. Hold pin in until in recovery mode with flashing lights*
  5. Launch TFTP32 go to the TFTP client tab
  6. Select server interface as my assigned ip of
  7. Set host as my assigned ip of and Port as 69 (instructed by TFTP recovery page on ubiquiti
  8. Browse to the recover image then click put

I was able to successfully recover it last time, but this time I can't

Did you upgrade the ubiquity boot loader after you installed a ubiquity firmware image upgrade that includes an upgraded boot loader version? I had to do this manually on my ER-X (since sold - I don't have one currently).

The ubiquity instructions state "On most EdgeRouter models, the bootloader version is not updated automatically with a firmware upgrade and must be updated manually".

If you did not do this step, unfortunately you are probably still on the version 1 boot loader, which does not support tftp recovery.

1 Like

By some miracle, I recovered and got it working, thanks for all the help guys.

Glad you figured it out. When I used an ER-X as my gateway router, I found OpenWrt performed better than stock on it. Once you get past the learning curve, I think you'll be glad you made the switch.

Mine could shape ~100 Mbps with CAKE and ~200 Mbps with fq_codel/simple QoS. If you are planning to run a VPN on it, Wireguard is a good option for this hardware. Installing (and enabling) irqbalance and activating packet steering seemed to spread the load over the 4 threads on the CPU a bit better on mine.

1 Like

While I haven't done much, I can already see it's much better in the areas I've tested. Pages load instantly, whereas EdgeOS always had a 1-5 delay. I don't even see the animation logging into gmail anymore, but EdgeOS I would get hit with the animation and loading bar every time. I also got a nice bump from 470mbps to 510mbps on OpenWRT. I also like how IPV6 is setup out of the box. Devs did a great job with this.