Flash Archer C7 v5 to stock firmware

Hi everyone, I'm new in this forum and my english is not perfect. I install open wrt on my tp-link Archer C7 v5(ca) and I world like to flash the stock firmware backlight. I tried with with TFTP and recovery procedure . I always have à time out error. Can you help me with this ?

1 Like

The Archer C7 needs you to run a tftpd, a server, from which (under a hardcoded IP) the archer pulls the accordingly named rescue firmware image, unless you have serial console access to the archer c7 itself, you should never see time out messages (they might be there, but you usually don't get the necessary access to observe them).

The message suggests to me that you're rather trying to use a tftp client, rather than the required tftpd server.

Hi, sorry for my late anwser. I was on vacancy. Here is some picture of my problem. I tried a lot of thing with your suggestion, but I still have the same problem. Here is a picture of the log. log%20err

Thanks a lot

Now a picture of my config.

And the last one.

Did you download the latest firmware from TP-Link? I'm using an Archer C7 v5 too and I was always able to reflash the stock firmware via tftp after renaming it to "ArcherC7v5_tp_recovery.bin".

I just checked my tftpd root directory and there is a firmware named "c7v5_us-eu-ca-jp-tw-up-ver1-0-4-P1[20180425-rel72768].bin" which is the latest from TP-Link and the one I used to go back to stock.

1 Like

I used the same firmware from tp link. Maybe there is something wrong with my procedure.


Hi, @turrican91.
I own a TP-LINK Archer C7 (US) v5 and I'm using OpenWrt 19.07.2.
I'm interested on revert it back to stock firmware. As I saw that you're experienced on doing this, I'd like to know how do you do it and which file do you use.

At https://www.tp-link.com/us/support/download/archer-c7/#Firmware I found this file named Archer C7(US)_V5_190726.zip
Will this file work?

Thanks for helping us!

Hi @gfcaetano,
I never tried that firmware before, but I had positive results with the download labelled "Archer C7(US)_V5_180425" on the TP-Link page.

1 Like

Thank you.
I've tried it through tftp and successfully got it back to stock.

Then I've realized that the stock firmware doesn't disable WPS even after unchecking WPS... Returning to openwrt.

1 Like

Were you able to revert back to stock using the 190726 stock firmware?

In which version of the stock firmware is the WPS not disabled even after unchecking?

Is the procedure to going back to openwrt same as the first time of flashing openwrt or just the snapshot image/install image is enough?

Just using a tftp server on my pc will work?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.