Fixing: Wrong version installation to router [VR200]

Before to star glanced to forum and couldn't find an identical one...

I want to install a latest snapshot to my router which VR200 from here yesterday (3 June or before release not 4 June). Its was development version so wifi 5Ghz doesn't stable it dropping connection from all devices- I did tried to reduce Wi-Fi power etc. but not worked- then I wanted to try another version below

tplink_vr200v-squashfs-sysupgrade.bin	91ba1925c8c542a293aa3b7310a5790acd96878cde63f6a4314962c9ea01f101	5056.3 KB	Sun May 17 05:22:40 2020

It was wrong version to VR200, I failed to notice VR200v and VR200 by an oversight.
The router freezing and doesn't start normally... and can't connect via ethernet and doesn't connect internet
(I was forced during installation process that was important error, but I ignored during rush installation, only checked sha256sum also accepted saving latest ISP configuration but doesn't work -normally-)

Then I said no problem then tried flash via 'serial console' again but,
I can't send any snapshot to device, stuck in sending image stage Retry count exceeded; starting again
I don't know why ?
Does my device bricked?
I can't found my mistake, Could you glance the details of my problem
What should I do?

Here some details

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 68:f7:28:5a:01:23 brd ff:ff:ff:ff:ff:ff
    inet brd scope global noprefixroute enp0s25
       valid_lft forever preferred_lft forever
    inet6 fe80::a014:cdd5:21a3:70f0/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 5c:c5:d4:3e:8c:a3 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp3s0
       valid_lft 3515sec preferred_lft 3515sec
    inet6 fe80::650d:f550:b7fb:95af/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
VR9 # setenv serverip
VR9 # mw.b 0x80800000 0xff 0xf00000
VR9 # tftpboot 0x80800000 openwrt-19.07.3-lantiq-xrx200-tplink_vr200-squashfs-sysupgrade.bin
16384 KiB S25FL128P_UNI_64K at 0:3 is now current device
MAC: ec-08-6b-9f-36-41  
Using vr9 Switch device
TFTP from server; our IP address is
Filename 'openwrt-19.07.3-lantiq-xrx200-tplink_vr200-squashfs-sysupgrade.bin'.
Load address: 0x80800000
Loading: T T T T T T T T T T 
Retry count exceeded; starting again

It's usually due to a firewall stopping the TFTP requests from reaching the server.

You might also want to use a short(er) name for the image file, issues have been reported with
long file names, in the past.


Thanks for help
I tried again some variants
tftpboot 0x80800000 t.bin
tftpboot 0x80800000 0.bin
Unfortunately not worked

First check of TFTP server configuration is running a TFTP client on the PC and confirm you can TFTP to yourself. That checks that the server is running, and the firmware file is in the right directory with proper permissions. It will not reveal a firewall problem though. Disable any firewall on the PC while doing TFTP. That is safe to do since the PC should not be connected to the Internet at that point anyway.


You hit the bull from eye,
I glanced tftp status, it wasn't active

sudo systemctl status tftpd
● tftpd.service - hpa's original TFTP daemon
     Loaded: loaded (/usr/lib/systemd/system/tftpd.service; disabled; vendor pr>
     Active: inactive (dead)
lines 1-3/3 (END)

Thank you so much :+1:‍‍

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.