First time user wanting to setup internet and bridge on Netgear DM200

Did the DM200 work in regular 'router' mode with your ISP, when it had Netgear OEM firmware?

As the DM200 only has one LAN socket, it's not possible to use the instructions in section 9.8 of the OpenWrt installation guide for HH5a, to configure 'bridge' mode

I recall there were forum posts in the distant past, regarding how to configure 'bridge' mode on DM200 with its single LAN port.

You could use the instructions in section 9.1 onwards, to verify OpenWrt is working with your ISP and the DM200 does not have any hardware fault.

fwiw, section 7.32 covers the 'Network device is not present' message.

Hey bill888 thanks for the quick reply. Yes even once the issue with the bridged mode came up for me on the Netgear OEM firmware the internet would work in router mode. That was part of my frustration because once I confirmed that was working, I just set the device to modem mode which locks down all the configurable settings on it, but my Orbi would no longer detect it had internet and on the Connection Status page it would show it wasn't getting an ip address from my isp and seemingly stayed in a constant disconnected state.

Ok I've had a look at the guide you suggested. I was able to follow the steps in the guide up to a point/ I set the Annex type to Annex B based on discussion here, specifically the last comment and third last comments. However this Australian isp modem settings guide is not clear to me and looks like it suggests A or B depending on circumstances I don't know. I've left the tone on auto as I wasn't certain. Potentially it should be B43 + B43C but hopefully auto will take care of it? I've set encapsulation mode to PTM/EFM as per the HH5a guide, and the DSL line mode is set to VDSL. I've followed the remaining steps, clicked Save and Apply after each relevant step then finally performing a reboot then a power cycle. When the dm200 comes back up the only change in the DSL Status section is that the Line Status changed from Idle request to silent and the unavailable seconds value had changed from 0/0 to have some numbers in it (this last part isn't shown in my screenshot of the DSL Status as that's from before I attempted the guide you suggested). I tried changing the Tone to B43 and B43c and power cycling the dm200 but I couldn't see any difference.

I had a look at section 7.32 but I couldn't really make sense of it or understand if there was anything it was instructing me to do, it seemed like it was just suggesting that error is normal and will clear once the dsl sync occurs.

Here's some screenshots showing what I set.

From what I can see perhaps I need to be going down this route? Netgear DM200 - OpenWrt does not support G.993.2


There is no info reported in DSL status overview (ie. no DSL sync), that's why OpenWrt is reporting 'Network device is not present'.

ie. Valid Annex, Tone and PTM/ATM are the only three settings required for DSL sync.
(VLAN, PPPoE etc does not affect DSL status overview)

It is possible the Lantiq firmware/blob which is supplied for use in OpenWrt upto 21.02 (which has not changed since 2016) is not compatible with your ISP. eg. it does not support Vectoring is one obvious missing feature.

The Lantiq firmware/blob included in Netgear DM200 OEM firmware will support Vectoring, and/or compatible with your ISP.

If you are not able to extract the Lantiq firmware from the Netgear firmware, another forum member may have a copy.

There is a separate forum thread for Lantiq firmware.
(See also section 7.27 of my guide)

fwiw, I don't know if this page maintained by xdarklight is up to date or not.

I forgot to add OpenWrt 22.03 prerelease may include a new Lantiq firmware/blob which supports vectoring. I could be wrong though. (note 22.03 also uses DSA, so any previously posts about DM200 bridge mode won't be valid due to changes in syntax in /etc/config/network file)

Thanks again for your suggestions Bill. I will read them now and see where I get.

In the meantime I have extracted the dsl firmware from netgear's oem firmware and tried the steps here but it didn't seem to change anything as far as the dsl status.

If you have successfully copied to the Lantiq firmware to the DM200 and the specified the path to the file, I can't think of what else to try.

Is it worth trying 22.03, because it supposedly has additional Vectoring support? Try both the default lantiq firmware and the extracted file. (Do Not keep settings when you upgrade/downgrade from 21.02 to 22.03)

Ok I'll give 22.03 a go, I've got nothing to lose and if worst comes to worst I have the other dm200 still on the oem firmware to mess around with anyway. I'll update soon.

ps. use LuCI and install the squashfs-sysupgrade.bin file.

22.03.0-rc5 for DM200

No luck unfortunately. I installed 22.03.0-rc5 without a problem and I made sure not to let it transfer my 21.02 settings across. I confirmed it was running the correct 22.03.0-rc5 version by checking at the bottom of the window. I tried the default dsl firmware and then copied the oem dsl firmware to the device and tried that too. I had a look at and tried to download the 5.9.0.C.1.7-5.9.0.A.0.2 version at the very top but the link gives me a 404 error. Can you suggest which of the other drivers on the xdarklight site I should try?

Maybe I could try downgrading to openwrt 18.06.1 as other people online have reported success with that version and the dm200.

I'm going to try the 18.06.1 firmware and if that doesn't work, I'm going to try changing ISPs. Some discussion seems to suggest TPG in particular may have a problem with this modem I'm using and vlan tagging. Why it's worked in the past I'm not sure but otherwise this scenario seems to add up.

Ok strangely enough when I went back and reconnected the internet cable to the dm200 it started showing activity on the led light and also on the dsl status page. Despite it having a signal and looking connected I couldn't seem to get internet on the laptop it was connected to. Changing the device name to dsl0.2 for the vlan id seemed to do it...or maybe that makes no sense and I don't really know what I'm talking about but things seemed to work in that order of my doing things this time around. And this is still on 22.03.0-rc5 with the dm200 dsl firmware set, I didn't get to trying openwrt 18.

So now I just need to see how to get it into bridge mode and then link it up with my Netgear Orbi it seems.

1 Like

The dot 2 is for vlan id 2

Yes that's why I'm using it.

You definitely do need to replace the xDSL firmware file in the OpenWrt images - the version supplied by default doesn't support G.Vector which is required for NBN FTTN/FTTB and while it will try and sync it won't succeed.

While the version included in the Netgear v1.0.0.66 factory image (5.7.B.5.0.7-, sometimes also referred to as will work, with NBN's recent SOS/ROC related changes the SRA function stops working in the downstream direction (upstream SRA still works normally).

To get the best results on an NBN FTTN connection with SRA working in both directions you need version 5.7.C.8.1.7_5.7.5.A.1.1 - see this post.

Edit: on the bridge topic you may find this post useful (indeed much of that thread is pertinent) but you don't need to worry about the special VDSL settings mentioned (e.g. Annex/SNR adjustment etc) - with a working xDSL blob as above you can leave everything on auto and it should sync up without problems.

I'd also suggest getting your connection working with standard router mode on the DM200 first (i.e. so your downstream router is behind a NAT rather than a bridge) and once you have the connection working that way look at the changes to bridge the DM200.


Yes, you have to create a custom device called 'dsl0.2' for your ISP's VLAN 2, if it wasn't clear in my guide that 'dsl0.101' is specifically for Openreach UK VDSL2 connections.

Good to hear you got internet working on the laptop.

1 Like

The DM200 does not support SOS and ROC or SRA:

Effective March 31, 2022, NBN requires all modems used with Fiber to the Node (FTTN) and Fiber to the Basement (FTTB) connections to support new stability features called Save Our Showtime (SOS) and Robust Overhead Channel (ROC), or an alternative called Seamless Rate Adoption (SRA). These new NBN requirements mean that some NETGEAR DSL modems and modem routers that previously worked with NBN FTTN and FTTB connections no longer work correctly due to hardware limitations.

Thank you very much for this. This is essential info. Unfortunately I have next to no experience with python and have struggled on my first brief attempts to run the scripts provided to extract that firmware. If you or anyone that happens to read this are more competent and are able to do it for me it would save me part of the difficulty I'm facing with this. Probably I can figure it out soon enough but I'm struggling and the whole situation and unrelated things has me stressed and burnt out on it.

I managed to get the dm200 with openwrt working and also cooperating with my Orbi however the dm200 wasn't bridged and also I entirely messed up that configuration once I tried to disable dhcp on both the modem and my router for my raspberrypi/pihole to do it. I'm thinking of trying to get back to that configuration and then just forfeit the pihole doing dhcp at the minor cost of not having clearly identifiable device names in the pihole logs.

I've also had a friend offer me his Billion 7800n modem/router which he has used in bridge mode before but it's about an 80 minute round trip to collect it and I'm not sure as of yet if that will be any more complicated or not than the tg789 modem/router I also have here which has bridge mode but I can't seem to get working in that mode either. Plus it would be a shame to render both dm200's useless to me and essentially EOL them, but it's looking increasingly like I will just have to eat the loss and write it off as bad luck as far as the NBN changing in March which appears to have affected this - although why it didn't stop working entirely around that time and never again I'm not sure but I trust that is why this is happening, along with my limited networking knowledge preventing me from thus far utilizing the workarounds.

Probably mostly not really need-to-know info but this issue has gotten the better of me and typing it out somewhat helps organize my thoughts.

The DM200 definitely supports SRA, confirmed by NBN compatibility reports. Netgear's firmware doesn't provide any control of this but SRA is enabled by default on VDSL (but not ADSL) connections by Lantiq's modem control API so the DM200 running either Netgear factory firmware or OpenWrt has SRA enabled by default for VDSL connections.

Take your time! :wink: While a little bit of stress can be useful, too much is bad for you! The DM200 DSL file version you've already extracted from the Netgear firmware will sync and run ok unless your downstream SNR falls much below about 6.5dB for any significant time during normal operation; if that happens there will be a full connection drop and re-sync (so a connection outage of around 3-4 minutes). Upstream SNR drops will still be handled by SRA so effectively no connection drop.

Once things are running ok (re-syncs excepted) with the configuration, then you can come back to extracting the Draytek xDSL file.

BTW: you want to stick with OpenWrt 22.03 rc3 or later as that version has fixes related to correct handling of VDSL vectoring control signals which make a huge improvement to connection reliability on G.Vector enabled lines like NBN's.

While I've not tried to do this myself, I believe that you'll need to keep DHCP on at least one of the devices for clients of your Orbi to be given the Pi-hole DNS records. Unless you need access to devices in your LAN from the internet or run gaming devices that complain about double-NAT, you should be able to run with the DM200 in router mode and have your Orbi also in router mode (though in different IP address segments, e.g. 196.168.1.x for the DM200 and 192.168.2.x for the Orbi). In this scenario you should be able to set the Pi-hole as DNS in the Orbi whether or not DHCP is running on the DM200 (the DM200's DHCP should only respond to Orbi client DHCP requests if the Orbi forwards them). Doing this then makes it easier to transition to the DM200 bridge configuration later.

BTW, you should be able to restore the default DM200 configuration in LUCI, or failing that by forcing a hardware reset.

If you're using Windows you'll need to install Python from - if you don't normally need Python installed, I'd install the latest patch release of v3.8 as the scripts were developed with that version. Open a command window and type "python" and you should get the Python prompt; type ^Z (i.e. control-Z) followed by return to exit Python.

Most recent Linux distributions will have at least Python 3.8 installed - running "python" from a terminal window should get the Python prompt which will display the version; type ^D (i.e. control-D) to exit Python.

With Python available, place the 2 scripts in the same directory as the ZIPped firmware downloaded from the Draytek site, then

  • unzip the firmware files so they're in the same directory as the scripts
  • make sure the working directory of your terminal/command window is set to the same directory as the firmware files and scripts
  • execute the following commands (assuming the Vigor 130 modem 11 firmware ZIP):
python v130_3841_modem_11.all
python v130_3841_modem_11.all.fw

You should then have 2 DSL files extracted in the same directory, one of which is for the 5.7.C.8.1.7_5.7.5.A.1.1 version needed.

Once you have the DSL files copied somewhere safe you can delete all the other files generated by the process (and on Windows uninstall Python if you don't need it for anything else).

Ok thank you for your patience and continued help. I've now been able to get the firmware extracted and it's working with the dm200 and as mentioned in one of the thread comments somewhere it works with the Tone, Encapsulation Mode and DSL line mode set to auto instead of having to set them to the specifics.

I've also had success by setting my Orbi RBR20 router to AP mode and turning off DHCP on my pihole for the time being. As it stands it doesn't seem like turning off DHCP on it is a compromise as pihole seems to be logging the clients under their network names. The only remaining things I can think of needing to do is work out how to forward ports in openwrt as I had previously done that via the Orbi's router mode. I also seemingly need to follow the rest of this guide but on my first go I got up to the second step but couldn't locate Network -> Firewall -> Custom Rules in Luci. It's late now but I will give it a go tomorrow.


22.03 introduces Firewall 4 and nftables which does things differently from the Firewall3 and iptables base of earlier versions which is why you couldn't find that item.

I'd recommend that you start a new thread specifically for running Pi-hole in conjunction with Firewall4 and nftables to tease out what needs to be done to implement a replacement for the functionality in that step of your reddit guide.