First time upload to D-Link DAP-1330 not working

When attempting to upload the OpenWRT firmware bin file, it gets stuck at "firmware uploading" on the D-Link GUI. I'm doing exactly what the Beginners Guide tells me to do, yet it won't install on my device. Has anyone else had trouble with the DAP-1330, and how did you fix it?

I don't know the device in question, but this commit might provide further insight:;a=commit;h=d265a8f2ca49a67a46493cf57de7c265855b317f

Sometimes bootloader based recovery mechanisms are a bit more lenient than the normal upgrade pages.

That is exactly what I was trying to do, but it doesn't work

I was able to get it. I was using the wrong file to upload to my router. For future reference, use the .img file to put it on the DAP-1330 the first time, not the .bin

The distinguishing factor is not the file extension, but what's just in front of it - namely 'factory' (to be used for the initial installation coming from the vendor firmware) versus 'sysupgrade' (to be used for upgrading between LEDE/ OpenWrt versions); this is generic for most routers.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)