First Install Xiaomi AX3600 can´t login via SSH

Hi, I am following the official guide to install OpenWRT and I have successfully flashed the required stock firmware version in order to proceed. Then I have chosen the JavaScript method:

and a window popup appeared asking for a password, I typed a password (lowercase 8 letters) and then I opened the terminal on my Fedora laptop to SSH into the router. However I continue to get the error when I write ssh root@

Unable to negotiate with port 22: no matching host key type found. Their offer: ssh-rsa

I looked at the internet I tried this command:

ssh -oHostKeyAlgorithms=+ssh-rsa root@

which did not work.

So I added the /~/.shh/config file and wrote inside:

    User root

it did not work aswell.

How can I SSH into my router? Is this error happening because of the JavaScipt method? should I try the other 3?

Isn't the default IP for OpenWrt though...

1 Like

That's the default IP of that router, and I need to connect to it prior to flash OpenWRT. I am following the instructions and I am stuck at the part when it tells to connect via SSH to the router in order to flash OpenWRT.

Nevermind, I solved that error and entered via SSH by adding:

    User root
    PubkeyAcceptedAlgorithms +ssh-rsa
    HostkeyAlgorithms +ssh-rsa

to ssh/config file

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.