Firmware upgrade? Or leave it alone!

I have a Chinese brand router, that came with OpenWRT pre-installed. It's worked OK for a year, but I occasionally get dropped connections. I was wondering if an upgrade in firmware might help. Here is the current info.
Model - YOUKU YK1
Firmware Version - LEDE Reboot SNAPSHOT r4594-6bdb662deb / LuCI Master (git-17.194.28316-2224714)
Kernel Version - 4.9.37

How should I proceed in identifying the correct firmware? Or would the consensus be to just leave it alone!

2 Likes

https://openwrt.org/docs/guide-quick-start/sshadministration

ubus call system board
2 Likes

Alright! I was hoping there might be a command like that lurking around.
"kernel": "4.9.37",
"hostname": "pretzel",
"system": "MediaTek MT7620A ver:2 eco:6",
"model": "YOUKU YK1",
"board_name": "youku-yk1",
"release": {
"distribution": "LEDE",
"version": "SNAPSHOT",
"revision": "r4594-6bdb662deb",
"codename": "reboot",
"target": "ramips/mt7620",
"description": "LEDE Reboot SNAPSHOT r4594-6bdb662deb"
BTW, I've been using Linux for 20 years, so I can find my way around a command line, configure networking etc. WRT I'm new to.

https://openwrt.org/toh/hwdata/youku/youku_yk1

5 Likes

Wouldn't it make sense to just wait for 19.03?

Update to 18.06.2 don't wate for 19.x because it could get pushed back. you never know! If you do update to 18.06.2 pleas dont keep settings as some config files have changed.

3 Likes

We want 19.x please :slight_smile:

Thanks to all for your replies, and thanks for the warning about not keeping the config, otherwise I would have checked that box. The upgrade seems to have worked, however there is a weird issue which I'm in the process of trying to fix:
I set up the wifi, network and DHCP ranges and that all seem to work fine. I connected a few clients and they were assigned a private IP address in the correct range. 10.10.10.x
But then I connected the router to the WAN. Now when clients in the private network connect, they are given a public IP address (and all in different subnets!) eg. 100.70.222.53, 100.70.45.56, which I presume are from my ISP's DHCP server which should be allocating an IP to my WAN connection. What's going on here? Is there some sort of DHCP passthrough setting I have to disable?

I guess it's your lucky day then... free IPs!!

1 Like

Can you confirm that you are connecting the cable to a dedicated WAN port, not a LAN port was used as WAN?

2 Likes

I agree with @Hegabo, it seems you [logically or physically] bridged WAN to LAN somehow...

BTW, those are from your ISP; but those aren't Public IPs:

2 Likes

OK, so when I discovered the 100.70.0.0/16 addresses, I swapped the router out for an older one, as there was someone in my house with a particularly urgent need for connectivity. (Mobile Legends!). I had a window to re-try it again today, and everything was fine, so yes, I have to conclude that I must have plugged the wire in the wrong hole. Interesting to learn that that was the outcome, which I wouldn't have expected. Also interesting to learn that my ISP was happy to dole out 4 IPs to my various network clients. Finally, ALSO interesting to learn about my ISP's extra natting, which now explains my recent failure to connect to my VPN, and the failure of acme letsencrypt certificates. Obviously CGN is cheaper than activating IPv6! Might be time to look for another ISP.

@lleachii Could you branch out this recent issue as it's different then the original subject?

No, I'm not a moderator.

1 Like

I have one too. It sometimes loose the flash, leaving me to reload. Undependable and extremely slow. I can ditch it at any time. It was only $17, but the specs looked so promising. Weird.

In my experience, the router has, on the whole, been OK, and definitely good for the price. I only have a small apartment and it covers the area sufficiently. I had a couple of connection drops every so often (which could have been a client problem TBH), but certainly no need to reflash.
So far the upgrade from 17.x to 18.x seems to have improved things, for the record, so case closed.

You could try and use tools like 'WireShark' or 'NetworkMiner' (omnious name, but a legit application). With these tools you can see what goes wrong with your network traffic. From these two tools WireShark has the steepest learning curve.

Not to say that your device isn't the culprit behind your packet losses, but with tools you will be able to pinpoint problems (or minor issues that could become problems) rather easily.

I'm familiar with wireshark and have used it for many years for network forensics. But this seems to be more of a problem between my Linux clients and the AP during WPA2 re-negotiation. Fingers crossed, no problems since I upgraded from 17 to 18.

OK, just going to close this out by saying it was definitely worth upgrading. I've had almost no issues with dropped connections since upgrading from 17.x to 18.x (which I thought was actually an issue with my linux desktop clients) and even think the coverage in the remote areas of my house has improved.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.