Firmware update resets

I accidentally used mtd to write the wrong firmware to a device so I then put itto recovery mode. go to the GUI, browser and enter the correct file name then click on Update firmware.

The only thing that happens is 'The connection was reset' and nothing else.
I can still get back to the recovery page however so what's going on?

Connection was reset is kind of normal, during an upgrade.

What's the device?
And what file was used by mistake?


The device is a gl.inet mango and I accidentally wrote a openwrt but for nanopi on it.
I know I lose the connection when upgrading but in this case, it also never stops pinging and I don't see any LED changes like I usually do.

So it's just throwing me out, it's not actually doing the flashing.

Depending on the size of the nanopi image, you might have wiped the flash of the Mango, except for the boot loader.

Geez, I sent this update to about a dozen of the mango's, does it mean they are bricked then? I have no remote access to them.

It's probably going to be hard to find out, without serial, or at least physical, access to one.

You should have one locally, to flash, before you mass upgrade ,)

1 Like

The recovery page is a tiny web server inside the bootloader. Often the standards compatibility is very limited and you'll need to use a specific browser, possibly an old version. See what advice GL has on the issue. This is not an OpenWrt question any more.


I'll ask there, thank you for the help.

The nanopi image BTW was 13M compressed, .gz

I'm not sure the problem is a gl.inet one at this point.
I've installed REALLY old browser and constantly get 'connection reset' when trying to upload then update the firmware using port 80 recovery.

I'm trying to upload even the snapshot build for this router and get the same.

I used a laptop and that worked so no idea what's just happened. A local network problem or something.