Firmware update gone bad Archer A5 v4

Hi i recently tried installing openwrt on my Tp-Link Archer A5 v4, after the image flashed the router was stuck in boot loop

I tried using the tftp method but without sucsess, i cant get the device to connect to the tftp server on my pc

After the furst try to put in tftp mode, it maybe wiped the old firmware but didunt find the new, So i was stuck with just the power indicator stayng solid green, and the bilt in switch led worked

But no mater what i tried, changed tftp servers, ip adresses, machines nothing helped, the device was going in tftp mode from what i see (power + wps light up for 15s and afther that it just reboot, probably due to not managing to find the tftp server)

Maybe i fried somthing along the way :frowning:
Any recomendations, and ways to fix it or its just it brick at this point?

At least you need correctly prepare firmware image for recovery. Something like:

dd if=stock_firmware.bin of=tftp_recovery.bin bs=512 skip=1

Then configure your PC ip-address and put tftp_recovery.bin file into tftp-server data directory.

Yeah no luck with that too :confused:

Any logs?
And my little error. Uboot request recovery file named tp_recovery.bin

As i said in the beginig the router dosent req any file from the tftp, it just boot in to the tftp for 15s after that reboots with solid green power led

The ip addresses that i tried are

On nither of them requests anything, and im out of ideas

Requests may be blocked by firewall/antivirus. Pls check.

I dont have any antivirus, or firewall bc ufw is disabled and iptables too nothing is blocking the trafic just the device dosent req anything :confused:

You could use wireshark to check what's happening on the wire, what file is request from which IP.

The problem is it dosent req anything at all, and i cant figure out did i bricked it in Total or what the hell is the problem

update: i did manage to find part of thr problem and that was the cable i was using but now i cant figure out why the tftp server dosent transfer the file over

here is a over view of what hapend, captured using wireshark

It's very strange. Uboot recovery do exactly:

set serverip
tftp 0x80060000 tp_recovery.bin;erase tplink 0x20000 0x7a0000;cp.b 0x80080000 0x20000 0x7a0000

In logs we can see that network setup and image download were completed correctly. So I assume fail reasons:

  1. Incorrect revovery image tp_recovery.bin including model/country code/structure.
  2. Unsupported flash chip (in this case uboot allows read operations but refuse any write ones).
    UART serial logs is hardly needed.

Okay but i dont have the serial console of the device (UART)
Is this the only way to tell it to copy the image over :expressionless:

Just for test try images from this archive. The images were prepared from EU and RU versions of stock firmwares.

the same result

Wait a minute! If I understand correctly your model is identical to archer c50 v4. So you can prepare recovery image as described in Wiki. Simply add 192k zero header to prev tp_recovery.bin files:

dd if=/dev/zero of=header.bin bs=64k count=3
dd if=stock_firmware.bin of=body.bin bs=512 skip=1
cat header.bin body.bin >tp_recovery.bin

What do you mean zero header? Can you Explain pls

If i understand corectly i need to add empty space to the image?

See this point


Wtf how ading a empty space fixes the image :-:

Uh i will try it out and write back with the result

The result was the same but i forgot to write back :confused:

Yeah no result from this :frowning: