Firmware Selector installs different packages than Attended sysupgrade

I try to build OpenWRT for tplink_archer-c60-v2 with dawn and one file for the HomeAssistant ubus communication with the Firmware Selector. This worked well so far, but I have some packages I cannot remove from the build: firewall4 & luci-app-firewall and several *nf & *nft

Building images for ath79 - TP-Link Archer C6 v2 (EU/RU/JP)
Packages: ath10k-board-qca9888 ath10k-firmware-qca9888-ct base-files busybox ca-bundle cgi-io dawn dropbear fstools fwtool getrandom hostapd-common iw iwinfo jansson jshn jsonfilter kmod-ath kmod-ath10k-ct kmod-ath9k kmod-ath9k-common kmod-cfg80211 kmod-crypto-aead kmod-crypto-ccm kmod-crypto-cmac kmod-crypto-crc32c kmod-crypto-ctr kmod-crypto-gcm kmod-crypto-gf128 kmod-crypto-ghash kmod-crypto-hash kmod-crypto-hmac kmod-crypto-manager kmod-crypto-null kmod-crypto-rng kmod-crypto-seqiv kmod-crypto-sha256 kmod-gpio-button-hotplug kmod-hwmon-core kmod-lib-crc-ccitt kmod-lib-crc32c kmod-mac80211 libblobmsg-json libgcc libiwinfo libiwinfo-data libiwinfo-lua libjson-c libjson-script liblua liblucihttp liblucihttp-lua libmnl libnftnl libnl-tiny libpthread libubox libubus libubus-lua libuci libuclient libucode libustream-wolfssl libwolfssl logd lua luci luci-app-attendedsysupgrade luci-app-dawn luci-app-opkg luci-base luci-lib-base luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-mod-network luci-mod-status luci-mod-system luci-ssl luci-theme-bootstrap mtd netifd openwrt-keyring opkg procd procd-seccomp procd-ujail px5g-wolfssl rpcd rpcd-mod-file rpcd-mod-iwinfo rpcd-mod-luci rpcd-mod-rrdns swconfig uboot-envtools ubox ubus ubusd uci uclient-fetch ucode ucode-mod-fs ucode-mod-ubus ucode-mod-uci uhttpd uhttpd-mod-ubus urandom-seed urngd usign wireless-regdb wpad-wolfssl ath10k-firmware-qca9888-ct base-files busybox ca-bundle dropbear fstools kernel kmod-ath10k-ct kmod-ath9k kmod-gpio-button-hotplug libgcc libustream-wolfssl logd mtd netifd opkg procd procd-seccomp procd-ujail swconfig uboot-envtools uci uclient-fetch urandom-seed urngd


Installing packages...
Installing libc (1.2.3-4) to root...
Installing libgcc1 (11.2.0-4) to root...
Copying /home/aparcar/asu/worker1/cache/22.03.5/ath79/generic/dl/libgcc1_11.2.0-4_mips_24kc.ipk.
Configuring libgcc1.
Configuring libc.

[...]
Installing firewall4 (2022-10-18-7ae5e14b-1) to root...
Copying /home/aparcar/asu/worker1/cache/22.03.5/ath79/generic/dl/firewall4_2022-10-18-7ae5e14b-1_mips_24kc.ipk.
Installing luci-app-firewall (git-23.093.42704-1c01c64) to root...
Copying /home/aparcar/asu/worker1/cache/22.03.5/ath79/generic/dl/luci-app-firewall_git-23.093.42704-1c01c64_all.ipk.
Installing uclient-fetch (2023-04-13-007d9454-1) to root...
[...]

Configuring libnl-tiny1.
Configuring libubox20220515.
Configuring libuci20130104.
Configuring libubus20220601.
Configuring libiwinfo-data.
Configuring libiwinfo20210430.
Configuring iwinfo.
Configuring liblucihttp0.
Configuring cgi-io.
Configuring liblua5.1.5.
Configuring lua.
Configuring luci-lib-nixio.
Configuring luci-lib-ip.
Configuring libjson-c5.
Configuring luci-lib-jsonc.
Configuring liblucihttp-lua.
Configuring luci-lib-base.
Configuring kmod-crypto-gf128.
Configuring libuclient20201210.
Configuring uclient-fetch.
Configuring libpthread.
Configuring opkg.
Configuring luci-app-opkg.
Configuring libblobmsg-json20220515.
Configuring ubusd.
Configuring ubus.
Configuring iw.
Configuring kmod-crypto-hash.
Configuring kmod-crypto-null.
Configuring kmod-crypto-aead.
Configuring kmod-crypto-manager.
Configuring rpcd.
Configuring busybox.
Configuring kmod-crypto-hmac.
Configuring kmod-crypto-sha256.
Configuring kmod-crypto-rng.
Configuring kmod-crypto-seqiv.
Configuring kmod-crypto-ctr.
Configuring libwolfssl5.5.4.ee39414e.
Configuring kmod-nfnetlink.
Configuring kmod-nf-reject.
Configuring kmod-nf-reject6.
Configuring kmod-nf-conntrack.
Configuring kmod-nf-conntrack6.
Configuring kmod-nf-nat.
Configuring kmod-nf-log.
Configuring kmod-nf-log6.
Configuring kmod-crypto-crc32c.
Configuring kmod-lib-crc32c.
Configuring kmod-nft-core.
Configuring kmod-nft-fib.
Configuring libubus-lua.
Configuring umdns.
Configuring libiwinfo-lua.
Configuring swconfig.
Configuring rpcd-mod-file.
Configuring rpcd-mod-luci.
Configuring luci-base.
Configuring luci-mod-system.
Configuring kmod-nf-flow.
Configuring libustream-wolfssl20201210.
Configuring kmod-lib-crc-ccitt.
Configuring getrandom.
Configuring libucode20220812.
Configuring ucode.
Configuring ucode-mod-ubus.
Configuring libgpg-error.
Configuring libgcrypt.
Configuring luci-theme-bootstrap.
Configuring procd-ujail.
Configuring jshn.
Configuring netifd.
Configuring jsonfilter.
Configuring usign.
Configuring openwrt-keyring.
Configuring ubox.
Configuring fstools.
Configuring fwtool.
Configuring base-files.
Configuring ucode-mod-uci.
Configuring kmod-nft-nat.
Configuring kmod-nft-offload.
Configuring libmnl0.
Configuring libnftnl11.
Configuring jansson4.
Configuring nftables-json.
Configuring ucode-mod-fs.
Configuring firewall4.
Configuring uboot-envtools.
Configuring libjson-script20220515.
Configuring procd.
Configuring px5g-wolfssl.
Configuring luci-mod-status.
Configuring luci-app-firewall.
Configuring kmod-crypto-ghash.
Configuring wireless-regdb.
Configuring kmod-cfg80211.
Configuring kmod-crypto-cmac.
Configuring kmod-crypto-ccm.
Configuring kmod-crypto-gcm.
Configuring hostapd-common.
Configuring kmod-mac80211.
Configuring kmod-ath.
Configuring kmod-ath9k-common.
Configuring kmod-ath9k.
Configuring ath10k-board-qca9888.
Configuring ath10k-firmware-qca9888-ct.
Configuring uci.
Configuring dawn.
Configuring luci-proto-ipv6.
Configuring rpcd-mod-iwinfo.
Configuring luci-mod-network.
Configuring luci-mod-admin-full.
Configuring luci-proto-ppp.
Configuring rpcd-mod-rrdns.
Configuring uhttpd.
Configuring uhttpd-mod-ubus.
Configuring luci.
Configuring luci-ssl.
Configuring dropbear.
Configuring luci-compat.
Configuring luci-lib-json.
Configuring luci-app-dawn.
Configuring kmod-hwmon-core.
Configuring mtd.
Configuring procd-seccomp.
Configuring urandom-seed.
Configuring kmod-gpio-button-hotplug.
Configuring logd.
Configuring rpcd-mod-rpcsys.
Configuring attendedsysupgrade-common.
Configuring luci-app-attendedsysupgrade.
Configuring kmod-ath10k-ct.
Configuring ca-bundle.
Configuring wpad-wolfssl.
Configuring urngd.

Finalizing root filesystem...
Enabling boot
Enabling bootcount
Enabling cron
Enabling dawn
Enabling done
Enabling dropbear
Enabling firewall
Enabling gpio_switch
Enabling led
Enabling log
Enabling network
Enabling rpcd
Enabling sysctl
Enabling sysfixtime
Enabling sysntpd
Enabling system
Enabling ucitrack
Enabling uhttpd
Enabling umdns
Enabling umount
Enabling urandom_seed
Enabling urngd
Enabling wpad

Building images...
Parallel mksquashfs: Using 4 processors
Creating 4.0 filesystem on /home/aparcar/asu/worker1/cache/22.03.5/ath79/generic/build_dir/target-mips_24kc_musl/linux-ath79_generic/root.squashfs, block size 262144.

[=============================================================/] 1091/1091 100%

Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
	compressed data, compressed metadata, compressed fragments,
	no xattrs, compressed ids
	duplicates are removed
Filesystem size 4584.85 Kbytes (4.48 Mbytes)
	35.35% of uncompressed filesystem size (12969.42 Kbytes)
Inode table size 9456 bytes (9.23 Kbytes)
	20.51% of uncompressed inode table size (46111 bytes)
Directory table size 13460 bytes (13.14 Kbytes)
	44.40% of uncompressed directory table size (30316 bytes)
Number of duplicate files found 151
Number of inodes 1399
Number of files 1079
Number of fragments 24
Number of symbolic links  201
Number of device nodes 1
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 118
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	qroot (0)

Calculating checksums...

I checked with
make package_whatdepends PACKAGE=luci-app-firewall
&
make package_whatdepends PACKAGE=firewall4
but there are no dependencies from other packages except luci-app-firewall depends on firewall4.

When I use attended sysupgrade and remove the packages there, the FW is built correctly without those packages, but I can't include files. How can I achieve the same functionality from attended sysupgrade with the Firmware Selector? Is there a dependencies unlisted or why are those packages included even though I remove them from the packages and even tried explicit removal with -firewall4?