Firewall4 NAT6 ipv6 masquerading

after update snapshot version, ipv6 stop work because nft replacing ipt nat6, can someone with experienced skill add new script to replace ipt to nft script? @vgaetera

1 Like

Firewall4 should support it natively, just set option masq6 1 on your wan zone.

Edit: seems there's a bug, masq6 is implemented in the ruleset but not parsed as option, will push a fix for it shortly.


is it done? are they implemented in recent snapshot version?

Yes it is done, no the package has not yet been updated.

1 Like

Any news?


use masq6 not working for fw4, works for fw3, any progress?

fw3 does not implement the masq6 option, maybe you should then disable masq6 in fw4 if it works without in fw3.

1 Like

In my case masq6 replace public clients address with router wan6 address

Ipv6 "NAT4 alike" with ULA never worked. Maybe my mistake

after tried a lot, I found windows cannot handle ipv6 local address, so must specify ULA to a public routable cidr

1 Like

Yeah, I can confirm that masq6 works fine at least in 22.03-rc4.

1 Like