Firewall config and web interface not working read-only file system error

I have upgraded my router's firmware (TP-Link WDR3600) from OpenWRT to LeDe but after the upgrade I don't have access to the web interface of the router anymore and I can only connect to it over SSH, even though I have luci and uhttpd installed. I have also tried to change the port forwarding settings on my router with vi /etc/config/firewall but it says that my file system is read only, so I am really stuck. I have even tried to upgrade the packages of my router with opkg update opkg list-upgradable and then opkg upgrade packageX but I got the same error. I have tried to issue as well mtd unlock rootfs_data but this also didn't help. I have also noticed that my root partition is 100% full. Any ideas, how I can change the firewall settings and also to mount in rw mode the root partition would be greatly appreciated.

Which LEDE firmware file did you use?

Sound likely that you have filled your flash memory, probably with the upgraded packages (which was rather unnecessary).

Full flash memory leads to read-only system.

Easiest might to clear everything with command "firstboot" and then reboot. This clears the router and you start from default settings, with no extra packages. Then manually reconfigure the router, but before installing check with "df" that your overlay partition has enough space to install new packages.

1 Like

The LEDE firmware is 17.01 not sure the last digit. Is firstboot going to flush all my custom settings?

It will revert all custom settings.

1 Like

You might review this OpenWrt wiki article on the recommended steps to take before doing an upgrade...

It may save some time and frustration identifying what customizations were installed.