File/Folder sharing in a routed client enviroment

Hi Experts,
I tried this configuration using routing, without masquerting.

I have already internet form the client subnet..

I cant see shares between 192.168.2.x and 192.168.1.x.
(typing \PC-NAME inside explorer)

In the 192.168.1.0 subnet shares between the AP clients are working. (I have done a wired test.)

I'm afraid that this won't work at all with the routed solution ?!

Here are my configuration files:
network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd00::/64'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '192.168.1.100'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 5 6'
	option vid '1'

config interface 'wwan'
	option proto 'static'
	option device 'phy0-sta0'
	option ipaddr '192.168.1.4'
	option netmask '255.255.255.0'
	option delegate '0'
	option gateway '192.168.1.1'

config interface 'wwan6'
	option proto 'dhcpv6'
	option device 'phy0-sta0'
	option reqaddress 'try'
	option reqprefix 'auto'
	option sourcefilter '0'
	option ip6ifaceid 'eui64'
	option ip6assign '64'

firewall:


config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'lan'
	option log '1'

config zone
	option name 'wwan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option mtu_fix '1'
	option log '1'
	list network 'wwan'
	list network 'wwan6'

config forwarding
	option src 'lan'
	option dest 'wwan'

config forwarding
	option src 'wwan'
	option dest 'lan'

Thanks in advance

After further investigation..
Typing \192.168.2.xx from a 192.168.1.x client doesnt work, same with \PC-Name.
But if i a disable temporary WIndows defender Firewall's on both maschines (Windows 11) the
\192.168....method is working ..
Name resolution is not working.
Have anybody fixed such a problem already ?

OK, i will answer myself..
It is/was a windows firewall problem.
In order to work you have to allow a smb connection to other subnet's.
In my opinion, the routed Repeater solution has to many disadvantages with the subnet trouble, therefore i decided to go back to the relayd solution.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.