File download issue using IPv6 address alone, disabled ipv4 at client side (laptop)

Hello all I am new to this forum, could you please help for this issue?

I am using OpenWrt 15.05.1 "Chaos Calmer" in my device and this device integrated with modem to connect the ISP, My ISP providing IPv6.

I have enabled IPv6 in the device using below configurations and I am able to get IPv6 address and able to reach network. But facing issue when I download the file.

Issue: File download not happening continuesly, stoped in middle and continueing after some time, it is occuring repeatedly until file download. No issues with youtube buffering I have tested by opening multiple channels no one struct or stoped.

My network configs: I have added "wan_modem6" configurations to enabel IPv6.

config interface 'loopback'       
        option ifname 'lo'        
        option proto 'static'     
        option ipaddr '127.0.0.1' 
        option netmask '255.0.0.0'    
                                      
config globals 'globals'              
        option ula_prefix 'auto'      
                                          
config interface 'lan'                    
        option ifname 'eth1'              
        option force_link '1'             
        option type 'bridge'              
        option proto 'static'             
        option netmask '255.255.255.0'    
        option ip6assign '60'             
        option multicast_querier '0'      
        option igmp_snooping '0'          
        option macaddr '28:80:A2:06:ED:E1'
        option ipaddr '192.168.1.1'       
                                          
config interface 'wan'                    
        option ifname 'eth0'              
        option proto 'dhcp'               
        option metric '1'                 
        option macaddr '28:80:A2:06:ED:E2'
        list dns ''          
        list dns ''          
                             
config interface 'wan6'      
        option ifname 'eth0' 
        option proto 'dhcpv6'
                            
config interface 'wan_usb'   
        option ifname 'eth3' 
        option proto 'dhcp'  
        option metric '10'

config interface 'wan_modem'              
        option ifname 'eth2' 
        option proto 'dhcp'  
        option metric '5'    
                             
config interface 'wan_modem6'
        option ifname 'eth2' 
        option proto 'dhcpv6'
        option metric '5'


Dhcp configurations: 
=================
added configs to enable ipv6:
-----------------------------------------
Under dhcp 'lan'
        option dhcpv6 'disabled'
        option ra 'relay'
        option ndp 'relay'

Under dhcp 'wan_modem6'
        option ra 'relay'           
        option ndp 'relay'          
        option master '1'           

Full config:
---------------
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '0'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option strictorder '1'

config dhcp 'lan'
        option interface 'lan'
        option limit '253'
        option dhcpv6 'disabled'
        option ra 'relay'
        option ndp 'relay'
        option start '192.168.1.2'
        option leasetime '24'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option master '0'
        option ndp 'none'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        option master '0'
        option ndp 'none'

config dhcp 'wan_modem'                          
        option interface 'wan_modem'
        option ignore '1'           
                                    
config dhcp 'wan_modem6'            
        option interface 'wan_modem'
        option ignore '1'           
        option ra 'relay'           
        option ndp 'relay'          
        option master '1'           
                                    
config odhcpd 'odhcpd'              
        option maindhcp '0'         
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

Thanks,
Viswa

That is 4 years old code. IPv6 support in 15.05 was still under development. You should upgrade to 17.01 or 18.06 or 19.07...

4 Likes

Hi hnyman, Thank you for your reply. All functionalities are working fine with my ipv6 changes except downloading.
Does any one enabled ipv6 in 15.05.01 release ? if yes, is it working fine without any issues (especially downloading issue) ? if so please let me know what changes have you done.

Sure, I had it running in it in 2015, but I do not have the respective settings any more.
Right now "nobody" uses 15.05 any more, as it is so outdated.

( The needed settings vary by your ISP's IPv6 distribution strategy and by the possible ISP devices like modem that you canät config properly.)

1 Like

Thank you hnyman. this issue occuring when enable SFE kernel module. It seems SFE not handling ipv6 functionality properly.

There is no SFE module in to the official OpenWrt repo.
(devs decided to opt for the flow-offloading kernel feature instead of the SFE approach (which is from Qualcomm and has not been adopted to the upstream Linux, to my knowledge))