Feedback Request: New Channel Analysis Feature in webui

Here we can collect Feedback about the new Channel Analysis Feature.
Post here any feedback, suggestion or issue with this new feature.
Screens are welcome.

The new feature is accessible by the Status menu in The LuCi webui

Some example of the Feature.


(thx hnyman)

11 Likes

Can't test the luci component, but definitely happy to steal the ubus component to make the Gargoyle plugin more robust :slight_smile:

1 Like

stealer ?!'!?!?!?!? ahahahha

Credit where it is due haha :wink:
When I saw your mailing list post I had hoped you might come up with something. I've never had the time to look at it. Has always been something else more important.

1 Like

Anyway i wonder if all the scan feature can be implemented using directly mac80211... But i think that is problematic for some special driver

1 Like

It actually works :wink:

3 Likes

One suggestion based on what we do in Gargoyle is to allow users to hover the name in the table and this causes the polygon on the graph to highlight or stand out, and vice versa.

Also have you tried graphing 80+80 (disjointed polygon)?

Your graphs are much prettier than ours by the way (here's an older version)

80+80 should work but can't test it. (the needed code is there)

About the highlight that's a really nice idea... Will try to implement that

I used hnyman's build for my R7800.
For 5GHz, it only works if the channel is set to 36. If any other channel is selected or set to auto, all other wifi will not be displayed.

channel 36 (5GHz)

automatic channel (2.4GHz)

2.4GHz works with the automatic channel selection.

For me it just takes some time for the otehr radios to show up in 5 GHz.
This is from R7800 with 5 GHz at channel 100:

And this is the same 5 GHz seen from ath79/WNDR3700v2 at the other end of the house:

Scanning while tuned to DFS channels isn't always possible (or legal), for ETSI this could only be added about a year ago, I have no idea about the current situation for FCC or MKK.

I set the country code correctly on the 5GHz (default was US). Now it works as expected. Thanks, it's a cool feature.

This has now been merged to OpenWrt master (iwinfo & rpcd) and LuCI GUI.
Thanks Ansuel :wink:

4 Likes

Should we close this or keep it for feedback?

1 Like

I consider the same after my own messages, but I thought that leaving this open might help to concentrate possible feedback.

1 Like

no dice... @rpi4

never mind wait for latest ipks
[root@dca632 /usbstick 46°]# opkg list-installed | grep -E '(libiw|luci-mod-status|rpcd-mod-luci)'
libiwinfo-lua - 2021-01-06-23d2722b-1
libiwinfo20210106 - 2021-01-06-23d2722b-1
luci-mod-status - git-21.007.61377-c49d33f
rpcd-mod-luci - 20201107

hmmmm... was libiwinfo 01-07 yesterday? need to test again... don't think these are the latest ipk's...

Sat Jan  9 22:25:00 2021 daemon.notice netifd: radio0 (29436): command failed: No error information (-524)
Sat Jan  9 22:25:00 2021 daemon.notice netifd: radio0 (29436): command failed: I/O error (-5)
netifd: radio0 (30447): WARNING: Variable 'data' does not exist or is not an array/object
ubus call network.wireless notify '{ "command": 0, "device": "radio0", "data": { } }'
 iwinfo wlan0 info | grep -E '(Channel|Center)'
          Mode: Client  Channel: 34 (5.170 GHz)
          Center Channel 1: 34 2: unknown

Yes, that is old and incompatible with the newest iwinfo library package.
You need version patched yesterday

1 Like

silly me forgot I had some wifi dongle plugged in as radio1... ( pi4 only has radio0 )... unplugged the non-enabled dongle and presto!

interesting kicks to 2.4 [top-tab-label] with the single phy... ( was in AP mode on 5Ghz prior to scan )... see over time if anything makes it scan 5... ( lol... didn't even look at the graph properly... appears to be combined! graph? )

So wait... I need more info...
radio0 is 2.4 or 5ghz (or both??)

both i think...

iwinfo
wlan0     ESSID: "ap101"
          Access Point: DC:A6:32:56:31:78
          Mode: Master  Channel: 36 (5.180 GHz)
          Center Channel 1: 36 2: unknown
          Tx-Power: 31 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgnac
          Hardware: 02D0:A9A6 0000:0000 [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: no  PHY name: phy0

maybe it was putting it in AP mode ( not client ) that got it to work also... ( not the dongle )

in client... you get these active:false... might be quirky bcm hw mode capability reporting... these are fussy things so dont sweat it too much...

ubus-when-non-working-in-client-or-dongle-mhz-error
{
  "objid": 375788760,
  "data": {
    "results": [
      {
        "channel": 1,
        "mhz": 2412,
        "restricted": false,
        "active": false
      },
      {
        "channel": 2,
        "mhz": 2417,
        "restricted": false,
        "active": false
      },
      {
        "channel": 3,
        "mhz": 2422,
        "restricted": false,
        "active": false
      },
      {
        "channel": 4,
        "mhz": 2427,
        "restricted": false,
        "active": false
      },
      {
        "channel": 5,
        "mhz": 2432,
        "restricted": false,
        "active": false
      },
      {
        "channel": 6,
        "mhz": 2437,
        "restricted": false,
        "active": false
      },
      {
        "channel": 7,
        "mhz": 2442,
        "restricted": false,
        "active": false
      },
      {
        "channel": 8,
        "mhz": 2447,
        "restricted": false,
        "active": false
      },
      {
        "channel": 9,
        "mhz": 2452,
        "restricted": false,
        "active": false
      },
      {
        "channel": 10,
        "mhz": 2457,
        "restricted": false,
        "active": false
      },
      {
        "channel": 11,
        "mhz": 2462,
        "restricted": false,
        "active": false
      },
      {
        "channel": 12,
        "mhz": 2467,
        "restricted": false,
        "active": false
      },
      {
        "channel": 13,
        "mhz": 2472,
        "restricted": false,
        "active": false
      },
      {
        "channel": 36,
        "mhz": 5180,
        "restricted": false,
        "active": false
      },
      {
        "channel": 40,
        "mhz": 5200,
        "restricted": false,
        "active": false
      },
      {
        "channel": 44,
        "mhz": 5220,
        "restricted": false,
        "active": false
      },
      {
        "channel": 48,
        "mhz": 5240,
        "restricted": false,
        "active": false
      },
      {
        "channel": 52,
        "mhz": 5260,
        "restricted": false,
        "active": false
      },
      {
        "channel": 56,
        "mhz": 5280,
        "restricted": false,
        "active": false
      },
      {
        "channel": 60,
        "mhz": 5300,
        "restricted": false,
        "active": false
      },
      {
        "channel": 64,
        "mhz": 5320,
        "restricted": false,
        "active": false
      },
      {
        "channel": 100,
        "mhz": 5500,
        "restricted": false,
        "active": false
      },
      {
        "channel": 104,
        "mhz": 5520,
        "restricted": false,
        "active": false
      },
      {
        "channel": 108,
        "mhz": 5540,
        "restricted": false,
        "active": false
      },
      {
        "channel": 112,
        "mhz": 5560,
        "restricted": false,
        "active": false
      },
      {
        "channel": 116,
        "mhz": 5580,
        "restricted": false,
        "active": false
      },
      {
        "channel": 120,
        "mhz": 5600,
        "restricted": false,
        "active": false
      },
      {
        "channel": 124,
        "mhz": 5620,
        "restricted": false,
        "active": false
      },
      {
        "channel": 128,
        "mhz": 5640,
        "restricted": false,
        "active": false
      },
      {
        "channel": 132,
        "mhz": 5660,
        "restricted": false,
        "active": false
      },
      {
        "channel": 136,
        "mhz": 5680,
        "restricted": false,
        "active": false
      },
      {
        "channel": 140,
        "mhz": 5700,
        "restricted": false,
        "active": false
      }
    ]
  }