FATAL ERROR: Received unexpected end-of-file from SFTP server


I can not access my OpenWrt device via a file transfer program such as FileZila in Linux Mint/Ubuntu. However, when I had a Windows machine and was using MobaXTerm I was able to connect and browse the OpenWrt server without issue. I have already looked on the MobaXTerm site but unforunately it is Windows (maybe mac) only.

Anyway this is the error message I received while trying to connect from both Linux Mint and Ubuntu.

|Command:|open root@ 22|
|Status:|Using username root. |
|Command:|Pass: ********|
|Status:|Connected to|
|Error:|FATAL ERROR: Received unexpected end-of-file from SFTP server|
|Error:|Could not connect to server|



What is the command/program you are running?

What are you trying to achieve?

1 Like
  1. FileZilla but happens in such programs too.
  2. Login to and browse OpenWrt via GUI.

Points 1 and 2 are unclear - or seem completely unrelated to your first post.

  • The "command" you're running is Filezilla??
  • And you're running "the Filezilla command" so you can login to and browse OpenWrt via GUI?

Can you please explain that in more detail?

Also, can you clearly explain how running "the Filezilla command" helps you "login to and browse OpenWrt via GUI"?

What is happening - what such programs?

Since Filezillais a graphical program and you pasted text output, this statement is unclear.

Anyone used sshfs client to OpenWrt? - #2 by vgaetera


There are serveral methods to connect use FileZila one of them is SFTP. All I did was enter the username, password and ip address of the server and pressthe connect button. There is no command that I physically type in.

If you are seeking assistance, please try to answer the inquiries.

Can you clearly explain why you're using Filezilla to "login to and browse OpenWrt web GUI"?

Please clearly explain the issue you're experiencing.

Have you tried installing openssh-sftp-server as suggested by vgaetera?


Or make sure you use SCP.


Doesn't look like FileZilla specifically supports scp.

Winscp supports scp and sftp.

For Windows I use WinSCP but as @frolic mentions make sure you use SCP as file protocol and not SFTP

1 Like


there are two options, use (win)scp, or install the sftp package, and keep using Filezilla.

1 Like

I am not trying to access the web gui.


Have you tried installing openssh-sftp-server as suggested by vgaetera?

No, I will try that.

@d687r02j8g @frollic

I am not using Windows but Linux.


Then use plain cli scp ?

1 Like

I have trouble remembering the commands.

That's what the man command's for ...

1 Like

What do you mean?



Thanks! That solved the problem, I can now log in the the server via SFTP.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.