Fast ethernet, but horrible slow wifi connection!

Hello!
Sory for english.
I I live in the country and use 3g/4g QMI modem inserted to my router Asus rt-n16.
If i use LAN connection - speed is 10-15mbit.
When i use wifi connection to this router - speed is 1-3mbit...
In my router firmware installed OpenWrt 19.07.3. I use standart driver b43
I tied remove all drivers and install another one - brcm80211, brcmsmac, brcmfmac, broadcom-wl - all drivers one by one from this page (https://openwrt.org/docs/techref/hardware/soc/soc.broadcom.bcm47xx#wifi_drivers).
If i install brcmsmac driver - in wifi settings appears a choice of 802.11n protocol. In this case - wifi connected on speed 144mbit, but the actual Wi Fi speed in all cases is 1-3 megabits. In other cases connection is 54 mbit and speed is same 1-3mbit.

I have another one 4g modem with wifi ondoard. And if you use that modem separately-just by connecting to the power adapter and distributing Wi-Fi from it-then the speed on that modem is good - 9-12 megabits.. Almost the same as over lan.

Here no anothe wifi points - only my wifi. there is no interference.

What could be the problem? Is the router dead? It was on the shelf for 5 years. And now I can't figure out what the problem is.
could there be incorrect settings?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb5:453f:9902::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.2'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '4.2.2.2'
        list dns '8.8.8.8'
        option delegate '0'
        option ipaddr '192.168.15.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 8t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 2 3 4 8t'

config interface '3g_zte'
        option proto 'qmi'
        option apn 'internet'
        option device '/dev/cdc-wdm0'
        option delegate '0'
        option pdptype 'ipv4'
        option auth 'none'

config interface '3g_huawei'
        option ifname 'eth1'
        option proto 'dhcp'
        option delegate '0'
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'bcma0:1'
        option channel '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option wmm '0'

Try enabling the WMM option on default_radio0, it has certain performance implications. I'd also try setting the channel to one that's least congested and set transmit power to max for now. Stick with 20Mhz channels on 2,4GHz wifi.

1 Like

I have a vague memory of the open source wifi driver being not so great on this platform and the CPU (SoC) is very slow so LAN-speed doesn't seem to be "bad" given the hardware.

wmm wouldnt help here, yet one shouldn't disable it as it disables wireless n features. in here chipset is broadcom (proprietary firmware), openwrt doesnt support it fully so you are not going to have 802.11n speeds and features.

you can try dd-wrt on your router if it supports. I think dd-wrt has somewhat more support for broadcom chipsets.

1 Like

Thx to All! I will look for a solution...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.