Failing install on GL-MV1000 / Brume

Reading it is fairly obvious that this device is still work-in-progress, but I tried giving it a go anyway. Reading these:

similarly indicate this isn't yet mainstream. Anyway the first page I mentioned above does point to downloads of 19.07.4 builds at

where interestingly some files are there multiple times just with different names. Now, the img files there all contain two partitions, as e.g. this output from the Linux file command shows:

DOS/MBR boot sector; partition 1 : ID=0x83, active, start-CHS (0x2,0,33), end-CHS (0x23,0,48), startsector 2048, 33280 sectors; partition 2 : ID=0x83, start-CHS (0x24,9,10), end-CHS (0x22d,3,19), startsector 36864, 524800 sectors

while the openwrt-mv1000-emmc-3.104.img file you can download from GL.inet has three partitions.

Using the uboot method (on this device, use the WAN port and release reset button when both power and wan light are on), I tried imaging with all of the .img files from the download area mentioned above and all failed and bricked the router. Using the image provide by GL.inet works as it should and it brings up GL.inet's usual interface with IP addresses in So my speculation is that the img files from openwrt download fail because they only have two partitions, while the one from GL.inet has three.

I feel I'm close but no cigar and if anybody can point me further, that would be very helpful.


1 Like

@bengsig - Did you ever figure this out?

I believe the directions are to client static ip of connect one end of ethernet cable, hold button for 3 or 4 seconds, release button connect other end of ethernet to wan or lan. http to going from memory, dont hold me to this