Failed update of OpenWrt on MR18

I have installed OpenWrt on my Meraki MR18 and it worked flawlessly for many months, and then I did sysupgrade and it got bricked.

Now it wont boot and I cant get reading on serial console, as it throws some gibberish characters when connected without GND and does not show anything on serial when I connect GND.

I am using my Raspberry Pi as UART serial.

Does anyone knows how to proceed with unbricking Meraki MR18?

Did you disable flow control on the serial port?

Yes, I did, and I tried with different speed settings, but with no result. The real question is why uart stops working when I connect GND.

without GND, the UART will pick up noise. you may want to try only GND and UART/RX only.
btw: which upgrade? to 18.06.1 ?

I tried only GND and RX but no characters appeared in the console, I tried also GND and TX, no change.

Yes, I wanted to update to 18.06.1 and to keep settings. Afterwards I tried to reset to defaults with keeping 30s/30s/30s reset button pressed, but it looks like the reset button has no function...