Failed firmware flash from 18.06.0 to 18.06.1; ea3500; extroot

Model Linksys EA3500
Configured to use extroot

I've previously tried to directly upgrade from version 17.01.4 to 18.06.1. This failed, but I was able to successfully upgrade from 17.01.4 > 17.01.5 > 18.06.0. When I tried to upgrade from 18.06.0 to 18.06.1 it failed.

I am also concerned that this upgrade somewhere along the way broke my extroot configuration, since all my installed packages are gone and Software shows only ~9MB of available disk space down from ~14GB.

Some advice regarding both issues would be appreciated.


Linksys Audi (EA3500)
Feroceon 88FR131 rev 1 (v5l)
Firmware Version
OpenWrt 18.06.0 r7188-b0b5c64c22 / LuCI openwrt-18.06 branch (git-18.210.69179-6df9a57)
Kernel Version

Not the help you are hoping to receive but to add to the dataset I have also had problems with my EA3500. I went from 17.01.4 to 18.06-rc1 then 18.06-rc2 failed. I was able to upgrade to 18.06 but 18.06.1 is failing. I am not using extroot.

1 Like

@tallpilot Thanks for adding your experience. I've since confirmed the exact same behavior on my second EA3500 that is identically configured (17.01.4; extroot): a) 17.01.4 > 17.01.5 > 18.06.0 > 18.06.1 failed; and b) extroot broken.

Is the problem you're having not being able to connect to the ea3500 after a flash? If so, that's the problem I've had with my ea3500 and the 18.06.* releases, what I eventually found was that after a flash and a failure to connect i could disconnect/reconnect the wired connection, not physically (removing the cable), but through the network manager (or windows equivalent), and once reconnected I could reach the ea3500 again. I don't use extroot so can't be of any help there unfortunately.

@mike No, I am able to connect via LUCI and ssh. It's just that the upgrade fails, although I've tried to flash the latest stable release (18.06.1) several times. It just won't take; and extroot is now broken.

EDIT: Flashed several times to two EA3500 devices, so the behavior is repeatable.

Linksys EA3500 / Likewise failed to update 18.6.0 to 18.6.1. After the update attempt, everything works on the previous firmware version 18.6.0.

1 Like

Hi the Bug Report is here:

@tapper Thanks man. Should other users ( @tallpilot , @mike , @dmitrox) report this bug as well, so we can get some traction on getting this resolved? What about the extroot is this to be expected behavior because of the version jump? Cheers

I think it might be viewed as bad form to make multiple bug reports for the same issue (although I really don't know for sure). I did some testing today and ran into the same problem, couldn't flash 18.06.1 from 18.06.0 or from one of my own builds. I thought I had 18.06.1 on my ea3500 at one point and find it hard to believe I could be remembering wrong, but I moved pretty quickly from 18.06.* to my own build because I couldn't get my ntfs drive working on 18.06.*, so it's possible I was still on 18.06.0 when I thought I was testing 18.06.1 with my ntfs drive. Either way, just another confirmation that there is a problem installing 18.06.1 on the ea3500, I even tried forcing it and it still didn't work.

edit - added a vote to the bug report and re-confirmed with a comment

@mike Sorry, yes Mike, not multiple bug reports for the same issue; but users adding their experiences to the existing bug report.

1 Like

Similar experience. EA3500

  • 17.01.4 > 18.06.1 Fail
  • 17.01.4 > 17.01.6 Success (packages gone :frowning: USB Share Gone) (Added feature to backup installed packages for easy reload would be nice)
  • 17.01.6 > 18.06.1 Fail
  • 17.01.6 > 18.06.0 Success
  • 18.06.0 > 18.06.1 Fail

Same problem here. The snapshot release upgrades so hopefully the next release will upgrade cleanly.

same case here.
cannot update to 18.06.1 from 18.06.0 or most recent snapshot r8381-4056be5, from ssh or web.
checksum is correct


It would be nice if someone could build image from this branch;a=shortlog;h=refs/heads/backport-18.06 which is going to be 18.06.2 released in a few days on 15th January. If you want working support for your devices in 18.06.2, then I think, that you should act fast :slight_smile:

Personally I don't have any experience with building images; and this is a bit short notice. :grinning:
Thanks for letting us know.

Let's hope it works with 18.06.2. Unfortunately, its a low priority bug and our hardware isn't very popular anymore.

But it's a solid router. Please fix :slight_smile:

1 Like

We can‘t fix due to lack of hardware and information. It would help if someone could capture the broken boot log via serial or at the very least bisect the commits between working 18.06.0 and 18.06.1

1 Like

It's usually possible to find this router on eBay for around $25,- shipped. Maybe some of us would be willing contribute a couple of bucks to get you one?
Otherwise could you please provide detailed steps on how to capture the boot log? I might be able to help with that in the next couple of weeks.

I'm in for $5