Failed ER-x move from EdgeOS to OpenWrt. Bootloader recovery?

I've been using my Er-X for a week and its already crashed twice with EdgeOS errors.
I thought I'd give OpenWRT a try on the ER-x.
I followed the instructions here-
Under User Experience. The first part went ok. I loaded the .tar file (custom “short receipt” factory Tar file) thru EdgeOS GUI. It rebooted into OpenWRT. There didn't seem to be any GUI available, so I SSH'd into root, then SCP's the bin file to the \tmp directory. Then use the sysupgrade -F -n /tmp/*.bin. The ER-X is now stuck with just eth0 active, I can't ping
I got hold of a serial cable and the bootloader is still ok, but with errors (i've got the boot sequence stored as a text file which I can't upload here). The last part of the bootloader text is below.
How is best to recover from here. Can I still load tftp OpenWRT straight into the bootloader (if so which file(s) or do I have to try and rollback to EdgeOS and try again from the beginning?

Creating 7 MTD partitions on "MT7621-NAND":
0x000000000000-0x00000ff80000 : "ALL"
Bad block detected at 0x9f40, oob_buf[0] is 0x0
0x000000000000-0x000000080000 : "Bootloader"
0x000000080000-0x0000000e0000 : "Config"
0x0000000e0000-0x000000140000 : "eeprom"
0x000000140000-0x000000440000 : "Kernel"
0x000000440000-0x000000740000 : "Kernel2"
0x000000740000-0x00000ff00000 : "RootFS"
Bad block detected at 0x9f40, oob_buf[0] is 0x0
[mtk_nand] probe successfully!
UBNT BD mac 18e829ac33d2 kidx 0 mrev 22 serial 18E829AC33D2 type e50
rdm_major = 253
GMAC1_MAC_ADRH -- : 0x000018e8
GMAC1_MAC_ADRL -- : 0x29ac33d2
Ralink APSoC Ethernet Driver Initilization. v3.1  512 rx/tx descriptors allocated, mtu = 1500!
GMAC1_MAC_ADRH -- : 0x000018e8
GMAC1_MAC_ADRL -- : 0x29ac33d2
Ralink I2C Init
TCP: cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
NET: Registered protocol family 15
UBI: attaching mtd7 to ubi0
Bad block detected at 0x9f40, oob_buf[0] is 0x0
UBI: scanning is finished
UBI: attached mtd7 (name "RootFS", size 247 MiB) to ubi0
UBI: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
UBI: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
UBI: VID header offset: 2048 (aligned 2048), data offset: 4096
UBI: good PEBs: 1981, bad PEBs: 1, corrupted PEBs: 0
UBI: user volume: 0, internal volumes: 1, max. volumes count: 128
UBI: max/mean erase counter: 3/0, WL threshold: 4096, image sequence number: 1040844687
UBI: available PEBs: 1938, total reserved PEBs: 43, PEBs reserved for bad PEB handling: 39
UBI: background thread "ubi_bgt0d" started, PID 54
UBI error: ubi_open_volume: cannot open device 0, volume 0, error -19
UBIFS error (pid 1): ubifs_mount: cannot open "ubi0_0", error -19
VFS: Cannot open root device "ubi0_0" or unknown-block(0,0): error -19
Please append a correct "root=" boot option; here are the available partitions:
1f00             512 mtdblock0  (driver?)
1f01          261632 mtdblock1  (driver?)
1f02             512 mtdblock2  (driver?)
1f03             384 mtdblock3  (driver?)
1f04             384 mtdblock4  (driver?)
1f05            3072 mtdblock5  (driver?)
1f06            3072 mtdblock6  (driver?)
1f07          253696 mtdblock7  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

The link I posted above has been updated- after I tried to load OpenWRT.
Anyway after lots of messing I got OpenWRT loaded.
I had difficulty getting the TFTP server working. I used a direct cable from my test laptop (with Solarwinds TFTP Server running) Lan port to the ER-x Port 1 (eth0).

I changed the setup- i connected the test laptop and ER-x to my Lan. Then tested the tftp from another PC. All worked ok. I suspect the TFTP server needs the laptop LAN Port to be active in order to setup correctly.
Anyway loaded the kernal.bin file from using tftp..
Once you have that running- the LUCI web interface should work. Be careful as this might clash with your existing home router if you use
DO NOT POWER OFF THE ER-x . If you do you've need to tftp the kernal.bin file again.
The first task is load the sysupgrade.bin file. I loaded it via the LUCI web interface.
Once you reboot again, you should have OpenWRT running. You can double check by powering off the ER-x, and once you power up again OpenWRT should still be running.
Hope that helps someone.

Had similar experience recently when using the lede-based minimal tar, however when using OpenWrt 18.06-based tar, the sysupgrade went without the hitch.

No need for serial console access, you can force the ER-X into tftp server mode and you can then tftp put the recovery EdgeOS file to restore it:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.