Fail to upgrade Mikrotik RB951g-2HnD to 23.05.0 -rc3

I had perfectly running 19.07 and decided to upgrade to 23.05.0 -rc3
I went through LuCI and got warning it's incompatible, but i forced.
Screenshot from 2023-09-06 21-17-53

It goes to reboot and this is it - brick.

Ok, as mentioned in /toh/mikrotik/common i've launched initramfs (https://pastebin.com/RtL77eSa) and tried sysupgrade -n squashfs
but it failed also

root@OpenWrt:/# sysupgrade -n /tmp/openwrt-23.05.0-rc3-ath79-mikrotik-mikrotik_routerboard-951g-2hnd-squashfs-sysupgrade.bin 
Sat Aug 19 14:20:26 UTC 2023 upgrade: Commencing upgrade. Closing all shell sessions.
Watchdog handover: fd=3
- watchdog -
Watchdog did not previously reset the system
Sat Aug 19 14:20:27 UTC 2023 upgrade: Sending TERM to remaining processes ...
Sat Aug 19 14:20:31 UTC 2023 upgrade: Sending KILL to remaining processes ...
[ 1185.012027] stage2 (2445): drop_caches: 3
Sat Aug 19 14:20:37 UTC 2023 upgrade: Switching to ramdisk...
Sat Aug 19 14:20:41 UTC 2023 upgrade: Performing system upgrade...
copy.c:252: write_file_to_mtd: unable to open file on MTD for writing: error -13 (Permission denied)
tar: write error: Broken pipe
copy.c:295: copy_file: copying failed: error -13 (Permission denied)
Sat Aug 19 14:20:41 UTC 2023 upgrade: Upgrade completed
Sat Aug 19 14:20:42 UTC 2023 upgrade: Rebooting system...
umount: can't unmount /dev: Resource busy
umount: can't unmount /tmp: Resource busy
[ 1189.369388] reboot: Restarting system

I've tried flash back 19.07, but the same issue.

Hi.
Start from scratch.
1st recover this unit using netinstall with any correct mikrotik firmware, ( hope you saved your licence keys ).
2nd proceed with a fresh new openwrt installation.