Fail to flash openwrt > 18.06 version on Netgear D7800

Hi guys,
I'm new in this forum, I wish I can help someone with my problem.
I follow the wiki for my modem+router device (Netgear D7800)

with tftp i'm able to flash the version 17.01.07 but if I try to flash >18.06 version like 18.06.4 or 18.06.1 or 18.06.0, the netgear keeps restarting itself continuously by flashing the LEDs.

I noticed that the partition reserved for the kernel has increased to 4MB. But I don't understand how to increase the reserved space in order to allow me to flash the new versions.

(I've also read that my netgear D7800 is similar to R7800 model)
Any help?

best regards,

I can't directly comment on how to install a current version, but for anyone with more experience with this device or its sibling, the commit message is (and suggests, to me at least, that TFTP installation is required).

commit 45b8a7c1a6
Author: Stefan Lippers-Hollmann <redacted>
Date:   Fri May 18 03:49:27 2018 +0200

    ipq806x: increase kernel partition size for the Netgear Nighthawk X4 D7800
    Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the
    2 MB reserved for the kernel partition by the OEM firmware anymore.
    This patch increases the kernel partition from 2 MB to 4 MB, at the
    expense of the rootfs, for all supported kernels.
    WARNING: This breaks sysupgrade! Flashing a firmware containing this
    changed partitioning from an older image with 2 MB reserved for the
    kernel partion requires the tftp recovery procedure, thereby losing
    all settings.
    This change follows the functional example of the Netgear r7800, but
    has not been runtime tested on a Netgear Nighthawk X4 D7800.

Like the commit that jeff quotes, likely you will need to use the Netgear recovery TFTP flashing process to flash the firmware (using the factory image).

Pretty easy advice is e.g in

Are you saying that you have already used the TFTP procedure with 18.06.4 and failed?


yes, i follow the procedure step by step, but every time I brick the modem :frowning:

sorry for the double post, this is the gif with the modem after flashing

That blinking is different than I have seen on R7800.

Might be that the bootloader for the modem (?) requires some additional modifications.

Somebody with D7800 should attach a serial cable and see what happens during the TFTP flashing and then during the boot process.

thank you for your support, what is strange in this situation is that I've read about many people that successful flash a >18.06 version without any problem with my same hw. It seems that they flash through official netgear d7800 web interface.
In my case I think is a problem of partition, because I successful flash the last 17 version.

Hey @kia :slight_smile:
I've read that you successful flash >18.06 version of openwrt, can I ask you how do you achieved that?

I tried with an other laptop (macbook air) with the same result, only the last 17 version work.
BTW now I've noticed that sometimes I cannot go to tftp mode by pushing reset button, after the flashing orange light it comes to white light without flashing.
I don't know why. After several try I can go to tftp flash mode. It seems without any change of my behaviour.

I have 18.06.4 working on Netgear D7800. Flashed it via atftpd ( and with the router in TFTP mode, as per hnyman's post, I just followed the debricking section. The commands I used were a little different as atftp doesn't have binary command and from memory, the transfer mode was in octal by default and so I took the gamble in just putting the file onto the router.

Used openwrt-18.06.4-ipq806x-netgear_d7800-squashfs-factory.img and it worked on the first try.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.