Face problem while installing openwrt in archer c60 v3

From the main web interface of tplink firmware while updating it says "invalid file format" . I also use tftp method the tp_recobery.bin file is uploading but there is no changes in firmware. please help me.

Did you see the note about latest stock fw and flashing, at https://openwrt.org/toh/tp-link/archer_c60_v2 ?

yes i see, but i am new user of openwrt, i can't understand how to perform uboot/uart method please help me

Not the point I was trying to make, but then you're out of luck.

The C60 isn't a great device for Openwrt anyway, it'll get EOLed soon, due to insufficient RAM and flash.
https://openwrt.org/es/supported_devices/864_warning

Have you tried renaming the filename to something short?

For Archer C60 v1.x, v2.0, v2.1, v3.0 installing OpenWrt is confirmed to work by simply uploading the OpenWrt firmware in the stock OEM's firmware-upgrade page. Please note however that this page will refuse to install firmware uploaded with a long filename. To bypass this limitation, download the relevant factory-flash bin-file and then rename the file to something shorter like firmware.bin before uploading.

yes i tried i rename the file to "firmware.bin" then i was trying to upload from stock firmware. while uploading web interface prompt a message "invalid file format"

Did you use factory image or sysupgrade one?

factory image only upgrade one installing. No i won't try upgrade image i will try.