Extroot uuid not working at startup

Hi to all,
I use a lede with usb stick as extroot (fs: ext4)
Below the fstab:

config global
    option anon_swap '0'
    option anon_mount '0'
    option auto_swap '1'
    option auto_mount '1'
    option delay_root '5'
    option check_fs '0'

config mount
    option uuid '<censored>-4d190ab8143e'
    option enabled '1'
    option target '/overlay'
    option fstype 'ext4'

config swap
    option uuid '<censored>-a22fed57f9bc'
    option enabled '1'
    option device '/dev/sda2'

This configuration work properly on normal tasks but if i try to reboot the system (without deleting /overlay/etc/.extroot-uuid before) the system start with an INTERNAL root.

At the moment the system are start with extroot and /overlay/etc/.extroot-uuid contains:

# cat /overlay/etc/.extroot-uuid 

The usb port used are same before and after restart.

Any solution for this issue?


Is that /etc/config/fstab file the one on the router or the one on the USB stick...?

After update to .04 the issue is not back again.