Extroot on 18.6 LEDE(solved)

hi i try to extroot on my tp-link tdw8970 but without success
ive got it work for 3 years on 17.4 what im on but after update it seems doesnt work with the same settings!

i try to reflash the old firmware but without success
is there any tip for make downgrade?

What process did you use? Did you erase the extroot device so that it starts fresh?

1 Like

yes i did
i make complete update without keep the old settings

i run this settings

mount /dev/sda1 /mnt

mkdir /tmp/cproot

mount --bind / /tmp/cproot

tar -C /tmp/cproot -cvf - . | tar -C /mnt -xvf -

sync ; umount /mnt

umount /tmp/cproot

sda1 is my usb 16gb
when reboot but nothink i cant see the extra memory like i do in previous version..
in old version ive got wifi radio worked like a charm with

  sleep 5
  while [ 1 ]
     wget -O - | madplay -
     sleep 2

exit 0

after update in put again this in my rc.local but it cant play!
it plays only if i put the command in putty

thanks for reply!

Did you edit "/etc/config/fstab"? Can we see it, please?


config global
option anon_swap '0'
option anon_mount '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '5'
option check_fs '0'

config swap
option device '/overlay'
option enabled '1'

config mount
option target '/overlay'
option enabled '1'
option uuid '7bff2f39-c3d6-d301-50ff-2f39c3d6d301'

config swap
option enabled '0'
option device '/dev/sda1'

config 'mount'
option 'target' '/'
option 'device' '/dev/sda1'
option 'fstype' 'ext4'
option 'options' 'rw,sync'
option 'enabled' '1'
option 'enabled_fsck' '0'

this is my fstab

I'm a bit confused now... why do you mount "/overlay" and then "/" from an external device?

What is the output of "mount"? Any errors during boot on "logread"?

1 Like

i really dont know whats going on here...
im confuses too
iv got no errors on logread
output of mount you mean in putty?if yes...

root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock4 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

Here is the extroot command I use. Just did it recently and it worked perfectly.

mount /dev/sda1 /mnt ; tar -C /overlay -cvf - . | tar -C /mnt -xf - ; umount /mnt

block detect > /etc/config/fstab; \
   sed -i s/option$'\t'enabled$'\t'\'0\'/option$'\t'enabled$'\t'\'1\'/ /etc/config/fstab; \
   sed -i s#/mnt/sda1#/overlay# /etc/config/fstab; \
   cat /etc/config/fstab;

and remove this

Your device is not mounting any external filesystem... have you installed all the required packages after the upgrade?

thank you very mutch!what worked for me!
excellent thank you!

another question if you could help me is what about the wifi radio what i have previous
could you help me with that?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.


Glad that worked!

I can't really help you with the wifi radio issue, but I'd recommend opening a new thread for that. Be sure to include the relevant details (config files, scripts, the specific symptoms, what works/doesn't work when you don't use the script, etc.).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.