Extroot and files

I have done this before, several times, and this is the code I'd run, reboot and then to System and there I will find 'Mount':

opkg update && opkg install block-mount e2fsprogs kmod-fs-ext4 kmod-usb-storage kmod-usb2 kmod-usb3

Then I'd reboot. But today, I noticed that after doing this, luci will be gone. That means I can no longer get to the webUI until I reinstall luci again. And round and round like this. Now luci is up and running now and I don't want to do it again. So I kindly ask. I've tried both versions of luci with and without ssl, same problem. I have run this a couple of times as well:

umount /overlay && jffs2reset && reboot now

As far as space on the device:

I am running the latest version of the firmware.

Define latest, please?

ubus call system board

OpenWrt 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branch git-22.335.71542-7e42425

And you're saying that LuCI is missing from that install if you reset to defaults?
What is the hardware in use?

Can you please run the ubus command I described earlier?

Is your extroot setup working?

@eduperez thanks. that's the thing. i cannot set it up without

and when i got that command run and installed, luci goes away, which means i cannot go to 'mount' and finish the setup for exroot. it's a catch-22 situation.

some update.
so i started over again, and reflashed the router.
installed nano and luci-ssl, no issues.
but when i tried to install the files for exroot, got these problems, at some point. See image, as it's perhaps easier:

and here's the output of free:
Screenshot 2022-12-03 at 18.10.06

@eduperez can someone please show/tell how to do this:
An easy way to free up some RAM is to delete the symlinks to /etc/modules.d/20-cfg80211, /etc/modules.d/21-mac80211, /etc/modules.d/2*-ath* and /etc/modules.d/[4-9]-

nevermind the space issue error, I can see 'mount' but can't get to it:

after a reboot, I get this:

Your JFFS2-partition seems full and overlayfs is mounted read-only.
Please try to remove files from /overlay/upper/... and reboot!

it would be good to know what i can safely delete from /overlay/upper/

and i'm looking at what is installed, is this normal, to have two of what looks like the same:

You have still not said what hardware you are using.

ubus call system board

If there is a squashfs option for your device, that will be more space efficient and make this easier to achieve.

Beyond that, the best option here is to use image builder to add/remove packages. You can do this with the firmware selector using the "Customize installed packages" option.


@psherman thanks a lot. can you please show/tell me how to run these commands and then within minutes, i can share the details from them.

ssh into the router and then issue the command

Then copy and paste the output to here. (when posting here, be sure to use the </> code block button to enclose the text for proper formatting)

root@OpenWrt:/etc/modules.d#     ubus call system board
	"kernel": "5.10.146",
	"hostname": "OpenWrt",
	"system": "Atheros AR9344 rev 2",
	"model": "TP-Link TL-WDR4300 v1",
	"board_name": "tplink,tl-wdr4300-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.2",
		"revision": "r19803-9a599fee93",

It would be VERY helpful to know the files that could be SAFELY removed. And that's a question I asked earlier :slight_smile:

I don't see how this information, which does not relate to space, which seems to be the issue, relates to that problem.

The WDR4300 has an 8MB flash chip, so the report of 64MB disk space means that you are running on a RAM disk. That happens if the overlay is full, it didn't mount properly, or the initramfs image is being used instead of the squashfs.

Whatever the case is, start by re-flashing the sysupgrade image and do not save settings. This should show about 1.5 MB of free internal disk space from a clean start.

There really isn't a good way to recover from overfilling the jffs. Reformat it and start over by re-flashing the whole OS.


And I'm not even sure that 'space' is the problem. Because clearly, we have a lot of it:

Screenshot 2022-12-03 at 19.05.17

Ok... so you are using a squashfs image already.

Do not install any more packages than actually necessary for extroot. If you pre-format your USB stick with ext4, you don't need anything more than this (which will fit):

opkg update; opkg install block-mount kmod-usb-storage kmod-fs-ext4

It tells us what hardware and what image you are running. This is very relevant (from the hardware, we can determine the amount of space available, from the image we can understand which version and which image type which relates to space utilization).

1 Like

No, you only have 8MB of flash space. You are mistaking RAM for flash storage.

@mk24 thanks. do you know how I do that on this router?