External IP addresses valid?

I’m using Archer C7 V5 running on 19.07.3 , connected to ISP via default WAN and Firewall settings
I’m pretty new to OpenWRT , but my observations are:
In status-> routes I see an strange external ip 169.254.16.120 linked to interface br-lan, is this normal?

In the system log I see very frequent the following:

daemon.notice netifd: wan (1516): udhcpc: sending renew to 10.160.231.129
Is this normal behavior for openwrt connected to WAN/internet?

169.254.16.120 is not an external address, it's a Link Local Address. Although I don't see any link local addresses in my routes, I can imagine that it's normal that you see them.

Yes. You get your WAN IP by DHCP, and that has to be renewed regularly.

2 Likes

This is not normal.
Please use ssh to connect to the device, run the following command uci export network, and copy-paste the output here in preformatted text.
grafik

Really?

user@machine:~$ ip -4 neigh
169.254.39.114 dev enp2s0 lladdr 00:xx:xx:xx:xx:xx STALE

(And from the router, I also see 21.4xxx.xxx.xxx IPs.)

I noticed this behavior after one of my phones upgraded to Android 10...and allowed randomized MAC addresses. I haven't verified it yet.

1 Like

Does it include matter if the neighbor cache contains odd addresses? If the route table doesn't contain a route to the address on the specific interface then the cache entry won't be used anyway I guess.

BTW the neighbor cache entry probably was added after receiving an ARP announcement (gratuitous ARP) from a device (possibly android as indicated above).

2 Likes

Yes really, because it means that some host didn't get the settings from dhcp and started broadcasting with the link local IP.

These can be from the wan side.

1 Like

Seen on br-lan...with the MAC of the device...identical to its 192.168.xxx.xxx entry?

(Granted, this may not be the OP's issue. I digress, as not to hijack the thread.)

1 Like

See below output of uci export network, can you see something strange?
By the way, I see that the mac address of the ‘strange’ br-lan entry is the same as one of the windows10 desktop running in my network, any idea how come?


uci export network
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        option ipaddr '192.168.0.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option delegate '0'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'ac:84:c6:8d:fb:a3'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

=> I’m not sure, as the renewal is for ip 10.160.231.129 and the ip address assigned by the ISP to my router starts with 178.84.xx.xx (as visible at the WAN interface) , or is this still ‘normal behavior to see renewal requests for 10.160.xx.xx?

The renewal request is send to 10.160.231.129, and is not for that IP. As you may know the IPv4 addresses are exhausted, and so your ISP has a good reason not to 'waste' a precious public IP address for DHCP purposes only. As every package not intended for an internal IP address is send to the gateway anyway, your ISP can catch the renewal request on any IP.

(BTW, the 10.0.0.0/8 block is reserved for private use. So technically you could build your network in a way 10.160.231.129 is an internal address. That would not be a good idea.)

1 Like

No, it looks alright. Most likely some host for some reason didn't get the dhcp settings and defaulted to the link local address.

2 Likes