Extending IPv6 connectivity to LAN clients from cellular modem

Hi! I'm playing around with a cellular modem and IPv6. Trying to get LAN connected clients IPv6 access. Running OpenWRT 19.07

My cellular modem gets a /64 IPv6 address on wwan0 interface. I can ping6 to the public internet.

Looking at similar posts, I changed my network and dhcp config to the following

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option ifname 'eth0'
   option proto 'static'
   option ipaddr '192.168.10.1'
   option netmask '255.255.255.0'
   option ip6assign '64'

config interface 'wan'
   option ifname 'wwan0'
   option proto 'dhcpv6'
   option iface_464xlat '0'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option force '1'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'
        option ip6assign '64'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option ra 'relay'
        option ndp 'relay'
        option master '1'
        option dhcpv6 'relay'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

My LAN connected clients get IPv6 address, but they cannot reach the internet. I can see the packets hitting eth0 and wwan0 on my tcpdump, but seeing no response. Is there something I'm missing? (Firewall is completely disabled for now)

Please upgrade to the most recent version of OpenWrt and provide details about your modem.

1 Like

Hi!

Thanks for getting back to me.

I've upgraded to OpenWRT 23.05.3

My modem is Telit FN990. I'm establishing connection using qmi in raw-ip mode. I can ping6 to the public internet just fine. The IPv6 address from the modem is received on wwan0. My LAN clients are connected to the eth0 interface.

With 23.05.3, my windows PC takes a long time but gets an IPv6 address in the same subnet. The default gateway, however, is empty. Running tcpdump on wwan0 and eth0 I can see dhcp6 solicit messages coming from the link local address of my Windows PC. I do not see any dhcpv6 relay-fwd messages anywhere though

There is no need to provide all these details.
Remove all your customizations (in interfaces, DHCP, etc.), switch the modem to MBIM and make configuration according to https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle
In addition to what is shown in the wiki, add option dhcpv6 '1' to wwan interface configuration.

Make sure option ip6assign '64' is configured on lan interface.

Once connection is established, show the output of

ifstatus lan
ifstatus wwan

Feel free to partially hide private information. Do not make screenshots.

Hi, Sorry does it have to be MBIM? It's just that this is part of my cellular modems learning/exploration. Starting with RMNET here and then going to QMAP (which should perform better than simple RMNET) and then ending all the way at 464XLAT.

I got the QMI stuff from here

How to step by step set up a data... | FAQ | Support | Techship

Next step QMAP --> Example on how to establish a dat... | FAQ | Support | Techship

My lan config has ip6assign '64', yep.

I never asked for these details.
It looks like you want to do things your way, so good luck.