Extender wireless clients only get IPv6 addresses. What am I doing wrong?

I have a TP-Link RE650v1. I flashed it with latest OpenWRT. All fine there.

This device is a wireless extender, and supports WDS (802.11n, 802.11ac). I followed the steps from this tutorial.

My issue is that when I run ip a show br-lan, I get this (slightly redacted):

6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether aa:aa:aa:aa:aa:aa brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.45/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdb6:dd0f:22c4::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::929a:4aff:fe1e:34f4/64 scope link
       valid_lft forever preferred_lft forever

So the ethernet port gets the IPv4 address. Which I can use to access the interface. I tried to disconnect the ethernet port, but the device was still not visible in the network as an IPv4 device (even after reboot). BUT, the wireless connection is successful.

Before flashing OpenWRT, I was able to use the IPv4 address of the extender to manage its interface. I don't want to hook an ethernet cable every time I want to manage this thing.

What do you guys think? Did I do something wrong?

here's my config (slightly redacted):

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'myWifi24'
	option encryption 'sae-mixed'
	option key '<password>'
	option wds '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'myWifi50'
	option encryption 'sae-mixed'
	option key '<password>'
	option wds '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'sta'
	option network 'lan'
	option ssid 'myWifi24'
	option encryption 'sae'
	option key '<password>'
	option wds '1'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'sta'
	option network 'lan'
	option ssid 'myWifi50'
	option encryption 'sae'
	option key '<password>'
	option wds '1'

/etc/config/dhcp:

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	list server '192.168.1.1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb6:dd0f:22c4::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'
	option stp '1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.45'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

In your dnsmasq config you have:

On the "Extender", try replacing that line with these 3 lines:

dhcp.lan.dhcpv4='disabled'
dhcp.lan.dhcpv6='disabled'
dhcp.lan.ra='disabled'

then reboot both ends.

My house has ethernet cables so not an expert in this but are two STA connections allowed?

Yes, but it will probably almost certainly create a bridge loop....

1 Like

Hi. Unfortunately that didn't work. In detail: I still can ssh to the device, but the device is unreachable once I remove the Ethernet cable, even though it's connected with wireless.

Btw, your comment about the bridge loop reminds me of a step in the tutorial:

Go to Network, Interfaces, Devices tab, Configure... on br-lan, Advanced device options and enable STP. Failing to do so can allow a network loop to form that will take down all routers.

Try removing the ethernet then reboot both.... not the other way round.

I'm sorry, when you say "both", what do you mean? It's just the extender connecting to some access point.

For the record, I tried rebooting multiple times. Still... It's unreachable with its IP address. Once I connect Ethernet, it works.

It works here, so I guess you have multiple things wrong...

What can I share to debug this issue? Is your configuration identical to mine?

No, different hardware, but it was a standard wds config.

Start by removing the following section entirely, meaning the connection will be on 2.4GHz at least for now. This will be more reliable at the expense of speed.

Now in the dnsmasq config, keep the 'disabled' changes I mentioned previously and change:

	option ignore '1'

to

	option ignore '0'

This will allow the extender to use dhcp from your main router.

Reboot both with the cable disconnected.

Now, on your main router, look at /tmp/dhcp.leases
There, if it is working, you will see the extender entry and have its ipv4 address.

If it is working, you can configure a static lease to make it easy.

I'll give it a shot. Thanks.

If anyone else can help too, I'd really appreciate it. I'll keep trying...