Extend wifi range and bridge (?) it to ethernet

Hi,

I have a TP-Link Archer MR600 LTE rooter (no WDS nor openwrt for it :frowning: ), and and two Xiaomi 4A Gigabit edition. I want to the the A4's in two slightly different configurations :

  • One will be linked with an ethernet cable to the MR600, possibily via the WAN port so I can still have two ports available, and will give net access to a computer (plus a printer if two ports are available), and via wifi to phones, laptops, ... in the office
  • The other one will work the same but would be connected to the MR600 via wifi. It still needs to be a wifi repeater / range extender because most of my laptops can barely connect to the MR600 in this area (garden)

I would prefer to have everything in the same subnet so everybody can easily access the printer but this is not mandatory.

I tried to follow Wi-Fi extender / repeater / bridge configuration, but IIUC:

  • on the ethernet side, relayd will just allow me to have same subnet and makes me loose IPV6 (which is not mandatory) compared to default behaviour ?
  • on the wifi side, it does not repeat the signal but only allow replacing the "wan" cable with a wifi link ?

I'm a bit lost about what I should do. Do I just need to set one client wifi client interface on one side, one wifi AP interface on the other, bridge everything, and use a cable between WAN port and the AR600 ?

Is there something I can read to understand all this better in 1 - 2 hours :smiley: ?

I managed to have the "garden" side working. I have not configured the ethernet part yet but it should be easy now. Here is a log of what I did :slight_smile:

bold means something that is written/selected in the web interface
fixed size means something you type in the web ui, or some input/output in from ssh (but you don't need it)

Starting point

  • One laptop
  • One TP-Link Archer MR600 LTE Router which provides internet access (I'll call it LTE Router),
  • One Xiaomi A4 Gigabit Edition running OpenWrt 21.02.0-rc3 r16172-2aba3e9784, which I want to use too relay the wifi signal (I'll call it OpenWRT Router)

I Factory reset OpenWRT Router (keep reset button pressed until a led start blinking, yellow led on the A4 Gigabit Edition)
The WAN port of OpenWRT router is wired to a LAN port of LTE Router
The laptop plugin in OpenWRT LAN
The laptop uses DHCP

Changing the OpenWRT Router LAN subnet

Both my LTE and OpenWRT routers have 192.168.1.1 as static IP and user the same subnet (192.168.1.x). I'll first change the OpenWRT LAN IP to 192.168.2.1 (hence the subnet of its lan side to 192.168.2.x).

Point a browser to 192.168.1.1, go to Network -> interfaces, click edit on the lan, change ipv4 field to 192.168.2.1. Click Save then Save & Apply

Now the laptop is given an adress in the 192.168.2.x range, and I can access the OpenWRT router on 192.168.2.1. With this setting, the laptop and the OpenWRT router have access to the internet. Lets install relayd.

Removing IPv6 on the WAN port of OpenWRT Router.

Browse to 192.168.2.1, go to System -> software, click Update List

I get:

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0-rc1/targets/ramips/mt7621/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.
...

I ssh to the OpenWRT Router, try to opk update, and get the same error. Using a navigator on my laptop I manage to find and download the file. So I try downloading it from the router:

root@OpenWrt:~# curl https://downloads.openwrt.org/releases/21.02.0-rc1/packages/mipsel_24kc/telephony/Packages.gz
-ash: curl: not found
root@OpenWrt:~# wget https://downloads.openwrt.org/releases/21.02.0-rc1/packages/mipsel_24kc/telephony/Packages.gz
Downloading 'https://downloads.openwrt.org/releases/21.02.0-rc1/packages/mipsel_24kc/telephony/Packages.gz'
Connecting to 2a01:4f8:251:321::2:443
Connection error: Connection failed

ok, IPv6 address...

I go to 192.168.1.1 (LTE Router web interface), and I see there is no IPv6 address given, probably by my 4G provider. I don't see any option here to remove IPv6 on the lan side, so I'll try removing it on the OpenWRT Router.

Browser to 192.168.2.1, Network -> Interfaces, Delete on WAN6, then Save & Apply.

Try opk update in my ssh console... Working! I stop the process and go back to doing it via the web interface.

Installing Relayd

Browse to 192.168.2.1, go to System -> Software, click Update List

In the Filter text input type relayd and install luci-proto-relay (which will also install relayd).

Open a private browsing window / removing cookies

The web interface complains about expired sessions. I try to reload but got an access denied. Opening a new private browsing window, I'm can log again.

I close it, go open a new (not private tab) to 192.168.2.1, got access denied, remove all the cookied for this website, and it works again.

Add an accesspoint

Network -> Wireless, remove both SSID: OpenWRT, on radio1 (the one which has 802.11nac which is better than 802.11bgn), Add. I choose operating frequency N (so my not 5GHz device can access it), check that Mode is Access Point, set ESSID to Garden. In Wireless Security, choose WPA2-PSK, enter a IWontGiveYouMyKey as Key (wifi password)

Save, Save & Apply

Now I can see and connect to the Garden wifi network, but it is useless (it doesn't provide anything interesting yet)

Add a wifi client

We now want to connect the OpenWRT Router to the LTE Router using wifi:

Network -> Wireless, on the Scan on the 802.11.nac adapter, Join network on the 5GHz network provided by the LTE Router. I let wwan for name of the network, and enter the passwork of the LTE Router wifi in WPA passphrase. I change the firewall zone to LAN.

Note: Maybe is it better to put the two different networs on two different networks and frequency range? I did not made any tests, I can reach 60MBps with this configuration which is enough for me)

Submit, Save, Save & Apply

Wait a bit and you should see in Associated Stations that the the routers are connected.

Bridge the two wireless networks

Network -> Interfaces, Add new interface, Name it LTERouterLink), for Protocol choose DHCP client, and Device select the wireless network to your router. Create Interface, choose Device again, and in Firewall Settings use LAN as Firewall zone. Save
Network -> Interfaces, Add new interface, Name it (e.g. Garden), for Protocol choose Static IP, and Device select the wireless network used for your access point (the one with the e.g. Piscine network). Create Interface, choose Device again, IPv4 adress set to 192.168.3.1, netmask is 255.255.255.0 and in Firewall Settings use LAN as Firewall zone. In Firewall Setting -> firewall-zone, choose lan again. Save
Network -> Interfaces, Add new interface, Name it (e.g. Bridge), for Protocol choose Relay Bridge, Create Interface. Relay between networks, select both LTERouterLink and Piscine or whatever you named your wifi networks). Save

Save & Apply

Test

Disconnect both cable (laptop to OpenWRT router and OpenWRT router to LTE Router), connect to the Garden wifi network with laptop. Speedtest says 70MBPs. Fine.