Excellent job with SQM (R7800)

Thanks for the help.
I am using TP link C2600.
I think I made a mistake last night by testing using LAN connection. I switched to WIFI this morning and it is much better:

Before I enable sqm:
before wifi

After I enable sqm:
after wifi1

I then increased download from 59000 to 70000, upload from 9000 to 10000, and tested again:
after wifi2

So it looks much better now. Will WIFI user experience be a lot different speed wise?

Thanks again.

I still would like to see your /etc/config/sqm and the output of "tc -s qdisc" otherwise I will just be guessing. BTW the shaper affects gross bandwidth, while a speedtest typically measures HTTP/TCP/IP goodput so you will never see the shaper's bandwidth in any reliable speedtest. Depending on the encapsulation and specific overhead you can expect (example calculation for DOCSIS):

59.0 * ((1500 - 20 - 20)/(1500 + 18)) = 56.7 Mbps (or 100*56.7/59.0 = 96.1 % of the specified bandwidth)

Thanks moeller0.
I am primarily a Windows user with very little knowledge on other things, so I am not really sure how to get those things you are asking for.

eth0 is probably the wrong interface. Try eth0.1 or some other one.

I checked and it shows eth0:
wan

But since the new speed test looks good, is there still anything I need to worry about?

Thanks!

Ah, have a look at https://www.turris.cz/doc/en/howto/ssh for instructions how to use a ssh terminal to access the router's command line; then issue commands 1. 2. 3., do a speedtest and then issue command 5.
BTW here https://forum.openwrt.org/t/sqm-qos-recommended-settings-for-the-dslreports-speedtest-bufferbloat-testing/2803 are some recommendations for configuring the dslreports speedtest better than its already decent defaults and how to best report the results.

Best Regards

if it's working fine then never mind.

I remember having issues where I selected eth0 in SQM with terrible results whereas changing it to eth0.1 fixed everything. I think it depends on the router and whether or not the WAN interface is part of the switch.

Well for routers that have a single CPU-to-switch port and use two VLANs to separate WAN and LAN functionality, setting up sqm on the non-MVLAN interface will result in WAN-to-LAN traffic being shaped to the minimum of the specified bandwidth, but that minimum will apply in both ingress and egress direction. Which is quite logical i one starts thinking about it; each packet from WAN to LAN will cross the underlaying interface twice once in ingress and once in egress direction and hence the oberserved shaping to the minimum is what one should expect. Doctor it hurts when I instantiate a shaper on the "raw" interface used to carry two VLAN interfaces with inversed directionality. "Don't do that then." But I digress...

Best Regards

I don't get it.
If WAN is eth0 when SQM should be set for eth0, right?

PNG3

I deleted this response since it is no longer an issue.
Thanks.

Yes that we I read from the Youtube tutorial:

  1. Select the interface. BE SURE TO CHOOSE YOUR WAN interface

On what device are you running theses?

Sure, but if WAN is eth0.2 and LAN is on eth0.1 putting sqm on eth0 will effectively set both download and upload to the minimum of the configured rates. In that case the "right" solution is to instantiate sqm either on the wan VLAN (eth0.2 in my example) or on the lan VLAN (eth.1). But this really is special for routers that use VLANs to separate wan and lan (from the cpu's perspective).

1 Like

Wrt1900acs v.2

@moeller0 - There's a new SSH for Newcomers page in the LEDE wiki. It's better than the Turris page because it only focuses on SSH, and recommends Cmder - a way better terminal emulator than Putty, SmarTTY, and others.

1 Like

I had the same issue with much slower speeds after SQM.
buffer1

Then I found out I used the wrong interface and fixed it but the problem persisted. I made sure to save changes and even restarted the SQM process/script using LUCI but I still got awful speeds. Then after rebooting the router, the changes seemed to stick.
So better not use the inappropriate interface or it will mess things up and needs a reboot.

Another sure way to know your WAN interface is from Network -> Interfaces page.

LEDE-WAN

Hi @richb-hanover,

ah, excellent, I will link this page from now on. Great work!

@cn008 - You might wanna edit your first post to show the mistake you made for other new folks finding this thread (ie to spare them from reading through all the other 20+ posts).