EX2700 Bricked I think IDK

Was looking for something to turn my EX2700 into an AP so I read up about ex2700 and someone said to rename the bin to img... So I downloaded the flash of openwrt from the page this one https://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/openwrt-ramips-mt7620-ex2700-squashfs-factory.bin

I renamed with .img extension.

Now for the life of me I cannot access the EX2700...

I am new to openwrt but have played around a bit with different hardware although I am a novice for the most part I have messed with esp's, JTAG's for IRD's etc.

I pulled the unit apart because I am thinking I may have to upload the firmware via serial.

This is all new to me though don't have the faintest clue on where to start what to upload what software to use etc. I am running WINDOWS 10 which I know complicates matters further for a lot of this stuff being that it is linux based etc.

Is it even possible to turn use the port as a ethernet port so I can use it as a wired AP instead of a wireless repeater / ethernet bridge?

If it isn't I'm just going to toss it in the parts pile I have no use for this repeating crud it just sucks up bandwidth of wifi antenna and craps it out further down the line repeaters are just a bad idea period there is little or no value in them for me personally I guess maybe the bridge part is useful but I have a bridge that works just fine from cisco.

I guess learning how to do this would be valuable I see the port speed is 57600 and (8) data bits, no (N) parity bit, and one (1) stop bit.

But it says nothing about a software that will work to flash it like the esp has several programs for flashing it the EX2700 I can find nothing that is tailored to it so I assume I will have to use putty.

Also the wiki says nothing of the VCC voltage in the serial section it points out the pin but that is it...

Is this a 3v or 5v vcc?

I'd like to get this going but need a little direction I've tried every IP on my network non of them work I tried direct wire to my PC that did not work either.

The power light is solid after boot the other lights are all off beyond that I do not know anything about it.

Before trying the big(ger) hammer(s), try to access your router via ssh (PuTTY is the common tool for this), as you picked a snapshot image without webinterface (luci) preinstalled;, root, no password.

If that doesn't work (and there's a good chance that it will), follow the advice given at https://openwrt.org/toh/netgear/netgear_ex2700#debricking - which appears to also offer binaries for windows.

Regarding serial access, if in doubt and not stated otherwise, you can assume 3.3 V - if you want to be sure, measure the voltage between GND and Vcc with a voltage meter.

Other than that, keep calm, get some tea and approach your recovery after a good night's sleep - it's easy to make the situation worse in a state of shock and in a hurry. Always try the less invasive methods of recovery first, before going for a bigger hammer. Having a linux installation handy (and be it a live ISO from USB or optical media) might make debugging easier than using windows.


I want to use USB to TTL adapter to program this Extender. "THE BIGGER HAMMER" as you call it.

Where can I find a detailed guide on how to do this from windows preferably?

Tea is an excellent beverage (unsweet) have plenty of it got that covered. I'm not worried about shock.

Okay so my first time messing with OPENWRT dually noted I can SSH into it and LUCI simply means web interface.

I typically run tomato shibby builds or brainslayer builds / kong builds DDWRT but I'm interested in what the lede builds are like and learning a bit more.

Just want some direction here to do things the hard way.

Don't connect Vcc

You only need Rx Tx and Gnd for UART/Serial


Have you searched how to do netgear recovery using tftp

If you have ssh access, your router isn't bricked and you have full access to do whatever you need.

https://openwrt.org/toh/netgear/netgear_ex2700#serial has all the device specific info of how to connect to the serial console of your device, https://openwrt.org/docs/techref/hardware/port.serial will give you some generic information on top. As soon as you have serial console access, your host OS doesn't matter anymore.

How much and what you can do with the OEM bootloader (u-boot in this case) is mostly device and/ or vendor specific, so checking similar devices (wiki, forum threads about device discovery or bricked devices) and (carefully) testing what is offered to you is the only generic advice I can provide. In general, the trick would be to invoke a tftp recovery mode of u-boot (assuming the vendor hasn't stripped this functionality) and either booting into a special initramfs image or uploading a new firmware image and writing it to flash from within the bootloader (again, what is possible here depends on the particular device in question).

This said, I need to warn again - as long as you do still have the option to access your device via ssh or invoke push-button tftp recovery, those methods are much safer and should be (strongly) preferred.

If you can ssh you should use sysupgrade to flash the release version, which contains the web interface.

Download the "sysupgrade" version to your PC: http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/openwrt-18.06.1-ramips-mt7620-ex2700-squashfs-sysupgrade.bin

Using the ssh / scp client on the PC, push the file to the /tmp directory on the router. On Linux this is very simple: scp filename root@ Here we are renaming the file to firmware.bin during the copy to simplify the next step.

ssh to the router and cd to /tmp. Use ls -l to check that the firmware is there.

Run the sysupgrade -n firmware.bin command on the router. The -n option should be used to make a clean re-install (keep No configuration files). The sysupgrade will reflash, shutdown, and reboot the router, which will take a few minutes. Be sure not to cut the power during this time.

Edit: This is a 4/32 device so you may have better results with the smaller kernel of the 17.01.5 build. If you are considering advanced applications you may need to make custom images, but that is a way down the road.

@mbo2o interesting how am I getting power the usb to ttl adapter has a 3.3v or 5v switch to use for the VCC pin once the extender boards are separated and the unit is taken apart it no longer has voltage so the chip needs its power 3.3v likely as stated. Oh the TTL adapter uses an FTDI FT232RL. No I did not search tftp methods I have recovered some routers using this method though so would not be a first time there although I hear it is different for cisco equipment than other equipment slightly so I may learn something doing it this way but as stated I can SSH into it already which I have used SSH a few times for different applications the most recent being LibreElec and previous reasons were Xbox and Linux builds but other than that I typically don't use SSH just another port open if enabled another method of attack you are likely enabling remotely is the way I always kind of looked at it so when I use it I turn it off when done.

SLH thank you that gets me more down the rabbit hole while general it gives some direction. I didn't come to heed warnings I came here to potentially break some stuff but I respect your warning and it should always be given in the case that someone truly needs it.

@mk24 Sweet SSH hrmmm guess I never SSH'd to a router either so maybe I'll do this first and at the very least check things out before I go messing about with serial but it doesn't take away from the fact that I want to get into serial programming but between the warnings of SLH and such maybe I should get the upgrade on it and play around a bit and see what openwrt is like. I have messed with console based routers very little as needed older cisco models and HP Pro Curve but I'd have to refer to literature as always. Now this is a pretty in depth guide for SSH and it is good to know that I can use smaller kernels and make custom builds this sounds like it could get interesting. Thank You as well I may give it a go this week depending on how well I do on laying underlayment and such kinda bummed out my back today so we will see may be moving like a turtle.

Thank You all that gives me something to go off of this is excellent!

No, you never connect Vcc - ever. Your typical usb2serial device (ftdi, prolific, silicon labs, wch, etc.) can't provide enough power for a router, the best thing that would happen while trying would be your usb2serial adaptor burning up, in worse cases it takes your computer with it.

Are you trying to power your EX2700 from the USB Adapter, don't do that.
Yes the adapter can be used to power some devices but not a router/extender.

Are you trying to power the USB Adapter from your EX2700, not necessary. The Adapter is powered via USB.

If you can't access the UART port/pins without separating the boards, then just solder some long wires while they are separated then put it all back together and connect your adapter to the wires.


You need to select the correct voltage on the switch because it not only controls Vcc but also TX/RX signals which need to be correct. It was mentioned in earlier posts that most routers use 3.3V

Wow okay thanks again a bit different than programming other lower power devices I thought the USB 3.1 spec would be enough to handle it but upon reading I seem to recall a small MA output from the adapter so of course makes total sense. Dunno wasn't thinking on that I suppose. I'll stick to powering device via other means like you say some dupont jumpers. Thanks again folks.

Just realized EX2700 is a wall wart. Are you sure you want to muck around with mains voltage and USB/Serail :frowning:

Take Care


Keeping the boards separated and working with extra low voltage makes sense now, do have an old power supply adapter or bench supply you can use.


You can flash any compatible image using tftp recovery


@mbo2o Of course have a bench top supply digital adjustable right next to the techtronix oscilloscope typically but I just moved so I am still living out of bins so I can dig it out... If I get the chance.


Thanks for the help @mk24 you were a great help got everything running right now the way I want it. To transfer files in windows next time suggest that a user first uses WinSCP instead in SCP mode. And then SSH in with putty and run sysupgrade as explained. After messing around a bit though I still want to mess with the USB to TTL port at a point I guess I'll hold off all I can say is OpenWrt is way way underrated in my honest opinion main stream use should be a bit more common imho but almost no mainstream folks use it typically you always see DDWRT.

I may migrate to figuring out how to make custom images at a point I'm trying to thing of how I can improve things further or even make the image custom for me. I would really like to mess about and add a dark theme vs the white with black text I'd like black and tennisball green or lime green text I'll have to see how everything is setup for appearance anyways as for other options hrmmm I'd imagine this thing is limited to some degree. But man is this thing a heck of a lot better than the original build. It allows for AP Mode while the original firmware really only allowed WDS bridging with ethernet bridge port essentially. This was all I really wanted to do got it accomplished a bit faster than expected. Thanks to all your help!

1 Like

Hello, trying this thread as I think I bricked mine. Just uploaded the factory openwrt firmware via web admin as adviced in the wiki but the router doesn't respond at all now. Don't even get a ping on (on a router and direct link with manual ip set). Nothing on nmap or nmrpflash. I tried netcat for udp but don't really know what to do with that... Reset btn doesn't work, obviously. Last time I did a serial/parallel connection to a device is from another age... is that my only resort? Cheers

Run WinSCP in SCP mode, Run Putty and Run sysupgrade as explained by mk24.

USB to TTL is an option. Still haven't messed around actually now I have this adapter with the code loaded but funny thing I don't even use the adapter I opted for a router that many don't know works very well with the right firmware so I can get it at 20.00 per router scored a few of them and I'll be running them for some time I believe. Bummer though that there is no OPENWRT support for the EA6500V1 only DDWRT a kind of weak and buggy support and Tomato but unless you do some digging you won't find the correct firmware that makes this thing really tick. A little known fact about this router is that it was the last home router that Cisco produced before selling its home router division. It is an awesome Access Point but don't expect good wired speeds for that get something else like an edge router.