Ethtool not detecting switch and other problems

Hi all,

I installed openwrt 18.0.62 for CF-E385AC. I used the openwrt generated sysupgrade.bin from the downloads.openwrt website.

I am facing a few problems:

  1. Unable to get into the AP
  • After the installation, I am unable to ssh into the board via WAN or LAN ports
  • I am unable to access LuCI via the LAN port (guess LuCI is not installed)

Solution:
Compile custom firmware (via imagebuilder) and add /etc/shadow and /etc/config/firewall files to the build.

firewall file:

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

With this change I am able to ssh via WAN (eth1.2) but not the LAN (eth0.1).

  1. After ssh-ing into the AP, I installed ethtool and ran it.
    ONLY the WAN (eth1) is connected but for some reason ethtool is showing that eth0 is connected.
root@openwrt:~# ethtool eth0
Settings for eth0:
    Supported ports: [ ]
    Supported link modes:   1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: No
    Supported FEC modes: Not reported
    Advertised link modes:  1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: No
    Advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: external
    Auto-negotiation: on
    Current message level: 0x000000ff (255)
                   drv probe link timer ifdown ifup rx_err tx_err
    Link detected: yes

root@openwrt:~# ethtool eth1
Settings for eth1:
Cannot get device settings: No such device
    Current message level: 0x000000ff (255)
                   drv probe link timer ifdown ifup rx_err tx_err
    Link detected: yes

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:0707:8667::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

I think this how the switch is configured. Please let me know if this is wrong:

Thanks!

Hi sunilobj,

I recently purchased a CF-E385AC and have a problem that seems related to your post a couple of months back.

I upgraded the firmware with the current stable openwrt version and only made a simple config for the wifi to enable it for testing. All my other settings are default. From my initial tests the basics work but there is an issue when booting with LAN or WAN cables attached. If cables are attached during boot neither the WAN or LAN interfaces receive packets but they are able to send packets out.

I did some basic investigation but have not solved the problem. The output of dmesg with cables and without is identical. Restarting the switch and the network from the serial console does not fix the problem. The output of ifconfig confirms no traffic is received on the LAN or WAN but shows sent traffic. Wireshark also sees the traffic going out. I also tried with the latest snapshot with the same results.

I suspect something is wrong with the switch which may be related to you issue here and I am interested if you were able to get this router to work?

Hi @coreym,

Sorry I missed your post. I have not yet figured it out. I tried multiple versions of openwrt without any luck :frowning:

Also, there was another issue. When you try to connect more than 5 clients on 5GHz radio, access point crashes. I was using stock (non-ct) firmware. You might be facing the issue, but please test and confirm.

I will post a solution as soon as I figure it out.

Good luck!

Out of curiousity, are you double nat'd? As in, the default gateway address of many devices is 192.168.1.1, which is the same as openwrt, causing a dns conflict when trying to connect. I've also noticed newer builds don't include LUCI by default (creates a smaller build).

I just flashed a COMFAST CF-E385AC with OpenWrt 19.07.3 and I am facing the same problem as @coreym is describing. DHCP is only working when I connect the cable after the device booted up. Does anybody have a solution for this issue?
I am using the default config and just changed the IP to 192.168.2.1.

btw over WLAN it looks like it is working properly