Ethernet works but wifi does not

Hi,

I have a mikrotik router that works as main router and has 3 vlans. The mikrotik acts as DHCP server for the VLANs. It is connected to my TP Link router running the OpenWrt 21.02 firmware. The mikrotik router is connected to the WAN port of the TP link router as trunk passing through all 3 VLANs. The I've set up interfaces for the different VLANs, and everything works just fine as long as I'm using cable connection.

When I try to add WiFi networks it fails to work properly. WiFi network seems to be up, but when I connect from the PC I get no IP address, and even if I trz to set up static IP in the address range of the dhcp I can't ping anything that works otherwise on the cabled network.

My network and wireless configs as below:

network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd70:27b6:d93f::/48'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option description 'vlan_1'
	option ports '0t 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option description 'vlan_2'
	option ports '0t 3 2 5t'

config interface 'IF_vlan1'
	option proto 'static'
	option device 'eth1.1'
	option ipaddr '192.168.10.2'
	option netmask '255.255.255.0'
	option delegate '0'
	option type 'bridge'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '4'
	option description 'vlan_IPTV'
	option ports '0t 1 5t'

config interface 'IF_IPTV'
	option proto 'none'
	option device 'eth1.4'

config interface 'IF_vlan2'
	option proto 'none'
	option device 'eth1.2'
	option type 'bridge'


wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'vlan_1'
	option encryption 'psk2'
	option key '<pw>'
	option network 'IF_vlan1'

config wifi-iface 'wifinet01
	option device 'radio0'
	option mode 'ap'
	option ssid 'vlan_2
	option encryption 'psk2'
	option key '<pw>'
	option network 'IF_vlan2'

Could someone please help me what I might be doing wrong?

Thanks