Ethernet speed is 40 mbps but wifi is 25

hi friends
i use openwrt 18.06.4 and mt7628 chipset on unielec u7628 modem
when i use ethernet cable in i get 40 mbp in downlaod but on wifi i have sow speed
i connect to wifi single device and i am close to modem
this is my wifi config
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/10300000.wmac'
option legacy_rates '1'
option htmode 'HT40'
option noscan '1'
option channel 'auto'
option country 'US'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid ' '
option key ' '
option encryption 'psk'

how solve this problem?

Wire less speed depends on the device you are connected to and on how many neighbors are using the same band. Try to select some wireless channel instead of auto (1, 6, or 11). But 2.4 band is very crowded nowadays.

1 Like

@komeilkma Please use "Preformatted text </>" for logs, scripts, configs and general console output.

Please edit your posting accordingly.


Getting 25 Mbps throughput on 2.4 GHz is actually pretty good.

1 Like

Not really if there are no neighbors. I used to have about 100.

1 Like

802.11n in a 20 MHz channel is limited to a modulation rate of 72 Mbps per stream. Taking packet overhead, beacon frames, ACKs, and other factors into account, getting half of that as throughput in a real-world situation is reasonable. Many client devices do not support MIMO.

From Tektronix, 802.11 Wi-Fi Physical Layer and Transmitter Measurements

Detailed report available at


That table doesn't look correct. It doesn't have 300Mbps on 40 MHz, etc.
I am now in rural area with only one AP here (mine). I have 300 Mbps connection and real transfer rate over 100 Mbps.
It is hardly achievable in other places.

1 Like

The chart is correct and can be confirmed through a variety of sources1. MCS indexes greater than 9 are multi-stream.

1 As three, publicly accessible references;,, (Note that the last reference appears not to cover 256-QAM, which some client devices also don't support)


Who said it is 1x1 MIMO?

1 Like

How can I fix this now?
Because with the same huawei modem with the same specifications I have a higher speed

As I wrote try to select channels.

1 Like

You can also check the connection rate in LuCI or with

iw dev <wlanX-Y> station dump

The MCS rate shown will change with time and traffic. I vaguely remember that one of rx/tx shows a low rate all the time for some drivers.

Edit: Looks like "idle" links show 6.0 MBit/s without further information from iw dev <dev> station dump

1 Like

Doesn't the automatic channel choose the best channel?

No, it selects the first possible (as supported by the hardware and allowed by the regulatory domain settings) channel, it doesn't do anything smarter - and it doesn't care if ch1 is crowded while 6 or 11 would be unused. You really want to make your own selection here and configure it accordingly.


you can use smartphone apps like Wifi Analyzer

To see what is the best (less crowded) channel at your position.


Not only is forcing 40Mhz channel width on 2.4Ghz likely illegal, if its then conflicting with nearby networks you will often end up with LESS speed than just sticking to 20Mhz on the least congested channel.

My performance has been improving on on 2.4Ghz lately and 5Ghz falling, likely the result of neighbors getting newer devices which favour the latter. A 20Mhz channel width with 2x2 MIMO should be easily able to handle 40Mbit, if it can't due to interference then 40Mhz is only going to make things even worse.


option encryption 'psk'


option encryption 'psk2+ccmp'


1 Like

Does it effect on speed?

Yes it should. WPA2 gives better speed than WPA in 2.4ghz N mode.

Not to mention the benefits from a security stand point...

Also, I'd recommend disabling legacy rates as well and sticking to 20mhz channels as previously stated:

option legacy_rates '0'
option htmode 'HT20'