Ethernet port problem

The MiFi device contains an ethernet port, when I plug in ethernet cable,
Realtek USB GbE Family Controller show "unrecognized network"

Ethernet can not get the correct IP
any suggestion?

eth0 Link encap:Ethernet HWaddr 1E:30:5B:64:46:3E
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:702 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:86565 (84.5 KiB)
Interrupt:45

Thanks

The best way to start is to evaluate your configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall

Hi psherman,

The network, dhcp, firewall config as below:
any config setting need to modify?


/ # cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:c029:3876::/48'
        option mipcInit '1'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option mode '1'
        option ifname 'ccmni'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option ifname 'ccmni'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'rndis0'
        list ports 'uap0'
        list ports 'muap0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

/ #
/ #
/ # cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '2h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config domain
        option name 'mobile.hotspot'
        option ip '192.168.1.1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

/ #
/ #
/ #
/ # cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Allow-LAN-DNS-server-in-xlat'
        option src 'lan'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '53'
        option src_port '1024:65535'
        option family 'any'

config include
        option path '/etc/firewall.user'

config include 'wanping'
        option type 'script'
        option path '/etc/firewall.d/wan_ping_block'
        option family 'any'
        option reload '0'
        option enabled '1'

config redirect 'qdmz'
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'all'
        option dest_ip '0.0.0.0'
        option name 'QDMZ'
        option enabled '0'

config rule 'lanudp'
        option enabled '1'
        option target 'ACCEPT'
        option proto 'udp'
        option name 'Allow-UDP'
        option src 'lan'

config rule 'blockweb'
        option proto 'tcp'
        option dest_port '80'
        option name 'Block-Web'
        option target 'DROP'
        option src '*'
        option enabled '0'

config rule 'lanweb'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '80'
        option name 'Allow-HTTP'
        option src 'lan'

config rule 'lanupnp'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '50000'
        option name 'Allow-UPnP'
        option src 'lan'

config rule 'lanssh'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '22'
        option name 'Allow-SSH'
        option src 'lan'

config rule 'lanping'
        option target 'ACCEPT'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option name 'Allow-Ping'
        option src 'lan'

config rule 'lanicmp6'
        option target 'ACCEPT'
        option proto 'ipv6-icmp'
        option family 'ipv6'
        option name 'Allow-icmpv6'
        option src 'lan'

config rule 'lanadb'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '5555:5583'
        option name 'Allow-ADB'
        option src 'lan'

config rule
        option target 'REJECT'
        option proto 'tcp'
        option dest_port '444'
        option name 'Disallow-https'
        option src 'lan'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

What version of OpenWrt are you running? Please provide the output of:

ubus call system board

What are all these extra ports... did you add them? Were they there by default?

The openwrt version is 21.02:

/ # ubus call system board
{
        "kernel": "5.4.179",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 0",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.2",
                "revision": "r16495-bf0c965af0",
                "description": "OpenWrt 21.02.2 r16495-bf0c965af0"
        }
}

You should upgrade your device to 22.03 (latest), but at least 21.02.5 to ensure that you are up to date with the security patches and bug fixes.

Meanwhile, what is the device you are using? And did you add all those ports to the lan bridge?