Ethernet port goes down immediately

So I have a new router (GL-MT6000 Flint 2) and I've put a snapshot OpenWRT on it. However, I had the same problem with the stock firmware and a snapshot of that so I don't think this is a recent problem - it may even be hardware not really OpenWRT.

I have an old device with a 100Mb/s Ethernet which was working fine on my old router. But now when I plug it in the port blips up and then straight down again. I can connect it through a switch but if I connect directly it just won't work. I get these messages:

logread
Thu May 23 09:17:57 2024 daemon.notice netifd: Network device 'lan4' link is up
Thu May 23 09:17:57 2024 kern.info kernel: [ 8175.079759] mt7530-mdio mdio-bus:1f lan4: Link is Down
Thu May 23 09:17:57 2024 kern.info kernel: [ 8175.085084] br-lan: port 4(lan4) entered disabled state
Thu May 23 09:17:57 2024 daemon.notice netifd: Network device 'lan4' link is down

dmesg
[ 8174.249232] mt7530-mdio mdio-bus:1f lan4: Link is Up - 100Mbps/Full - flow control rx
[ 8174.257098] br-lan: port 4(lan4) entered blocking state
[ 8174.262319] br-lan: port 4(lan4) entered forwarding state
[ 8175.079759] mt7530-mdio mdio-bus:1f lan4: Link is Down
[ 8175.085084] br-lan: port 4(lan4) entered disabled state

try to disable autoneg and force the port speed using ethtool.

Wow thanks - this fixed it:

ethtool -s lan5 speed 10 duplex full autoneg off

I thought it was 100Mb/s but obviously not!

Sorry to be a noob but how do I get that set on reboot? Is there a config file or should I put in a script somewhere?

add it to /etc/rc.local, before the exit 0 line.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.