Ethernet-less Dlink DCH-M225 after install accessing problem

i successfully installed LEDE 17.01.4 factory on, but something went wrong: Dlink DCH-M225 is a wifi repeater without ethernet ports, so i was expect to find wifi default enabled, but after flashing no SSID is broadcasted and device seems to be isolated.
Now i revert back to OEM FW, but i need to know how do i access device after LEDE flashed.

Thank you

Regardless of the device, wlan is never enabled by default - so you do have to find a different way way to access it after flashing from the OEM firmware to LEDE. This could be (beyond ordinary wired LAN) having serial console access or building a custom image with a default wlan setup.

I supposed that device-specific lede firmware was already customized, but, as you tell me, this assumption is wrong, so i've to learn how to manually compile a custom image or wait for someone uploading a wifi-enabled custom image for Dlink DCH-M225.

Pressing the WPS button should enable the wireless radios.

tried already, nothing happens either in 17.01.4 or 17.01.1.
also tried keep WPS pushed or combination WPS&reset, same result, no wifi visible

I see now why the WPS button doesn't work.

tried already, nothing happens either in 17.01.4 or 17.01.1.

How are you doing an upgrade/access the AP if the wireless doesn't start? Would it be possible that you test an fixed 17.01.4 image?

I am having the same problem with DCH-M225 please enable wifi by default on the next version or perhaps enabling the radio with the WPS button, another idea could be adding wifi config options after the factory reset procedure on the recovery menu.
Thank you,

Hello again,
Is there any solution to the DCH-M225 problem?
I opened the device and there is no easy way of wired connection to the device.
Please let me know if anyone figured out how solve this problem.

Hello again,
Unfortunately the current firmware version lede-17.01.4-ramips-mt7620-dch-m225-squashfs doesn't work, so without changing the code and recompiling don't waist your time as the dch-m225 cannot be accessed after the firmware upgrade. The good news is that it is possible to recover to original d-link firmware by using the reset+ power (holding the pin in the reset hole for about 5s while powering the unit), an open wifi network appears and the recovery menu can be accessed using a browser on ip
Hopefully this is a help to other people stack with the current lede-17.01.4 version.


In trunk version it works. Only the audio section not work correctly. 44100hz audio is not played fine, only 48000hz

did anyone manage to have this working for this router?

This seems to have been addressed in a code commit way back in 2016:

Would be nice to have this in the standard build.

is it possible to compile a firmware with this change? The existing .bin file is limited by the lack of wireless

Thank you!
Good day, on link you may download firmware with wi-fi is ON default, SSID OpenWRT no password