/etc/rc.local running script with "&": job control turned off

Hi,

I use the background script since a long time successfully on OpenWrt. It forks from /etc/rc.local as a background process in bash.

Now - when booting the router - logread tells me :

Jun  3 09:45:29 WifiAP-01 procd: /etc/rc.d/S95done: /root/wrtservice: Creating new service instance ...
Jun  3 09:45:29 WifiAP-01 procd: /etc/rc.d/S95done: /root/wrtservice: set: line 72: can't access tty; job control turned off

How can I turn on job control, because I'd like to use "bash /root/wrtservice stop" which now does no longer kill the whole "wrtservice" process group. It did so before.

  • OpenWrt 21.02.0-rc2, TP-Link Archer C7v2

Guessing now, but create a custom init script for the daemon ?

1 Like

Ok, I'll try that and report back :).