Establishing a 802.11s mesh

Hello folks,

ambitious openwrt newbie here.

I'm planning to establish a 802.11s mesh with 3 Zyxel WSM20 (Multy M1).
One of the devices should work as the router and will be connected to the modem of my ISP. The additional 2 devices are supposed to cover my whole flat (maybe one will be enough).

I've read a lot in the last hours, of course also
https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s and https://openwrt.org/docs/guide-user/network/wifi/mesh/mesh11sd

Assuming I would follow the configuration shown in the mess11sd article with

A typical mesh interface configuration in /etc/config/wireless would look something like:
 
   config wifi-iface 'mesh0'
     option device 'radio0'
     option mode 'mesh'
     option encryption 'sae'
     option key 'secretmeshkey'
     option disabled '0'
     option network 'lan'
     option mesh_id 'PublicFreeMesh'
 
 The Default mesh11sd configuration file looks like this (/etc/config/mesh11sd):
 
   config mesh11sd 'setup'
     option enabled '1'
     option debuglevel '1'
     option checkinterval '10'
     option interface_timeout '10'
   config mesh11sd 'mesh_params'
     option mesh_fwding '1'
     option mesh_rssi_threshold '-80'
     option mesh_gate_announcements '1'
     option mesh_hwmp_rootmode '3'
     option mesh_max_peer_links '150'

I have a few questions

  1. General understanding: Is the mesh established this way 'only' the communication channel between the mesh points or what I see when I scan for wifis on my end device?
  2. Do I have to establish one or more wifi interfaces first or is it sufficient to establish a mesh in this way?
  3. In the default configs above is set which radio to use but not which wifi protocoll (a/b/g/n/ac/ax). Where do set this? Or isn't it necessary?

Can you help me?

Thanks in advance

I don't fully follow your questions, but they indicate you are seriously thinking in depth about the subject so I will try to give you answers to help and reinforce your understanding.

First, I should clarify/reiterate some important points you will have read in the user guide articles:

  1. An 802.11s mesh configuration supports a wireless backhaul, ie a communication method between similarly configured meshnodes.

  2. Normal devices cannot connect to a mesh network and they have to rely on a mesh gateway device.

  3. A mesh gateway is a meshnode that also has Access Point (AP) functionality that, from the point of view of a normal device, looks like a normal AP.

  4. An 802.11s meshnode takes no part whatsoever in user device roaming from one AP to another. This is purely an interaction between the device and the access points and is an entirely separate subject (despite some manufacturers using the term "mesh" incorrectly for marketing purposes).

Moving on to your questions:

  1. An 802.11s mesh is normally the only communication channel between mesh points. If you scan for "wifis" on an end user device, you may or may not see the mesh network. Older devices might show the mesh, newer will not.
    The older devices are showing the mesh in error, but in any case an end user device will not be able to connect directly (except for some very special cases involving jail-breaking or rooting of the mobile device and we are not going to go there in this thread).

  2. A mesh node will have at least one wireless interface, for the mesh. It may also have a wireless interface or more for use as an AP, thus becoming a "Mesh Gateway".
    The default OpenWrt config will have an AP configuration. The mesh configs shown in the user guide are usually added to the default config, resulting in a mesh gateway configuration.

  3. The operating mode of the physical radio is configured in the wifi-device section of the config and not shown in what you posted.
    A typical wifi-device section would look something like this:

config wifi-device 'radio0'
   option type 'mac80211'
   option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
   option channel '1'
   option band '2g'
   option htmode 'HT20'
   option disabled '0'
2 Likes

Thanks a lot for your reply,

the devices haven't been delivered yet. So I am still not able to get practical experience. A few days left ...

In the interface config do I have to decide which radio (the Zyxel WSM20 have to) of the devices is used for meshing or can I setup mesh0 on radio0 and mesh1 on radio1, assign both to network mesh and the devices decide what is best?

Which network do I have to assign the mesh interfaces to? Directly to lan or is it better to have a separate network mesh?
The examples in the wiki pages of 802.11s and mesh11sd differ in this point.

Choose one only. If you set up mesh on two interfaces and bridge them together then by default you will have bridge loops.

A simple way to think of it is to remember the mesh is a layer 2 mac-routed network. Use it as if it is a virtual unmanaged switch. Your "lan" is a layer 3 network eg an ip subnet. To extend your lan, use the mesh. In this way the lan of your router will be the same subnet as the lan of a remote meshnode, just like it would be if you connected with cables to a switch.

The examples in the wiki pages of 802.11s and mesh11sd differ in this point.

Can you point out where it says this?

1 Like

My understanding of what you wrote is to assign the mesh to the network lan. Right?

The wiki page https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s says:

config wifi-iface 'mesh'
        option network 'mesh'
        option device 'radio0'
        option disabled '0'
        option mode 'mesh'
        option ifname 'mesh0'
        option network 'lan'
        option mesh_id 'my-mesh-id'
        option encryption 'sae' # or 'none' if you do not want encryption
        option key 'your-secret-password'

while https://openwrt.org/docs/guide-user/network/wifi/mesh/mesh11sd says:

  config wifi-iface 'mesh0'
    option device 'radio0'
    option mode 'mesh'
    option encryption 'sae'
    option key 'secretmeshkey'
    option disabled '0'
    option network 'lan'
    option mesh_id 'PublicFreeMesh'

The difference is that the first example assigns the mesh Interface to the network lan AND mesh and the second one assigns it to the network lan only. What is the benefit of assigning to the network mesh or is that wrong?

1 Like

The first example was wrong - I fixed it.

2 Likes