Espressobin and latest OpenWRT

Hi,

I have an Espressobin (v5, I think). I notice that the latest supported OpenWRT version is 19.07.7 in the TOH but that there is a 21.02.2 release.

Can I safely upgrade to 21.02.2?

The platform is popular and widely supported (mvebu target) so I think it's more that noone bothered to confirm it working, rather than it being broken.

Given the target audience and the price tag I don't think it's as popular as its Linksys WRT AC siblings. Those all work fine on 21.02 from what I know.