ERX SQM Performance Issues

Finally got this running on version openwrt 21.02

I've enabled a DHCP server, set my lan address.

Turned on SQM Cake on ETH0. Values are:

200mb down
35mb up

Speed test shows 150 down, 35 up. Tons of bufferbloat on the upload, none on the download. I've even increased my values, and I start to get bufferbloat with no increase in speed.

Connecting directly to my modem through my computer I can get 1400mb down

I thought this device with cake would do about 200 down?
Not sure why the upload is still getting tons of bufferbloat. Thoughts?

I use Cake with Piece of Cake.

I set down/up values to approximately 95% of my ISP's advertised speed.

I would start there, and back off in 5 to 10% increments.

Use a wired connection for testing.

If you are using DSLReports Speed Test, use the HTTP option.

The HTTPS option has been broken for a while, due to expired SSL certs on the test servers.

I have 50/10 service on vlan35 here. I enable sqm to pppoe-wan interface 50k/10k ingress/egress, layer_cake or pieceofcake, 44byte PPO. YouHua WR1200JS results:
[http://www.dslreports.com/speedtest/69201951]

I tried this. I can't get over 150mb/s with SQM cake w/ piece of cake.

Tried rebooting too.

I am using HTTP. Also using speedtest to test my speed after. Is there something else I need to configure?

Should I be applying this to my WAN port or my individual LAN ports?

Applied to WAN