ERX OpenWrt Brick?

I started with the EdgeOS v2.09 hotfix I believe

I flashed the part 1 firmware openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar using the EdgeOS System Flash

It rebooted, and I'm trying to flash part 2, but now I can't connect to the ERX to send the Part 2 file over.

Was using command
pscp.exe C:\Users\Tyler\Downloads\openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin root@
Also tried the same command with SCP instead of pscp.exe

I get "ssh_init: Network error: Cannot assign requested address"

Putty also can't connect.

Windows 10
Ethernet directly from Desktop to ERX Eth1

Can't ping

The only way I can get it to ping, is if I assign to IPV4 and connect to Eth0

I'm not really sure what is going on. WinSCP also can't connect.

What should I do next?

Did you follow the instructions on the wiki? Either way, I'd try reverting to stock (wiki page has instructions for that as well) and try to install OpenWrt again. 21.02 just went stable and is recommended, btw.

I did. I reverted to stock v2.0.6 and tried again.

Downloaded the first link, flashed via EdgeOS System


Can't access the OpenWRT WebUI.

Changed ethernet port to Eth1, tried assigning a static IP, tried dynamic, can't seem to get this working.

You tried right? Basically anything not .1, since the ERX is supposed to set itself to that. That's not getting you connectivity on none of the ports?

1 Like

I just tried assigning and as static IPs

And while one of them was assigned a static IP, I tried navigating to and respectively

I also tried this while I was set as a dynamic IP.

Am I missing something very basic?

Can you paste the commands like you execute them? From what you're entering in your terminal?

In my last attempt, I've strictly been trying to access the openWRT interface after I had flashed the 1st firmware file via EdgeOS System Upgrade tool

I should be able to access this right?

If I attempt to do this via command line, what should I set my device static IP too, or do I leave this dynamic? I was going to use this command:

pscp.exe C:\Users\Tyler\Downloads\openwrt-21.02.0-ramips-mt7621-ubnt_edgerouter-x-squashfs-sysupgrade.bin root@

What I meant is the output the console prints after you scp over the initramfs image and try flashing that. It might be you need to hook up serial to see what's going wrong with phase 2.

Hope this is what you wanted. After I execute that pscp.exe command I posted it says:

ssh_init: Network error: Cannot assign requested address

Or were you looking for the commands after I flashed the initial firmware from EdgeOS?

Yes, the first phase is the initramfs image. You already shared what you're getting when you try to flash the final firmware image, which is phase two.

Please use code tags to post code our code output btw, the </> button in the editing ribbon on top of your message composition window.

I think at this point you should hook up a serial cable though to see what's actually happening.