Error while compiling ImageBuilder on Gentoo

Hello there!

I want to compile image with openwrt-sdk-ar71xx-generic_gcc-7.3.0_musl.Linux-x86_64.

My environment: Linux-4.16.3-gentoo-x86_64-Intel-R-_Core-TM-i7-3630QM_CPU@_2.40GHz-with-gentoo-2.4.1

Gcc: x86_64-pc-linux-gnu-7.3.0 ; Binutils: x86_64-pc-linux-gnu-2.30 (linker mode = ld.bfd)

Model: TP-Link TL-WR743ND Ver.2 (it's available from menu)

I have done all preparations as mentioned in manual, but at some stage getting error:

../lib/libext2fs.a(ismounted.o): In function `check_mntent_file':
ismounted.c:(.text+0x23d): undefined reference to `major'
../lib/libblkid.a(devname.o): In function `probe_all':
devname.c:(.text+0x8dd): undefined reference to `makedev'
devname.c:(.text+0xc26): undefined reference to `makedev'
devname.c:(.text+0xceb): undefined reference to `makedev'
collect2: error: ld returned 1 exit status
make[6]: *** [Makefile:425: e2fsck] Error 1
make[6]: Leaving directory '/home/leopold/source/build_dir/host/e2fsprogs-1.43.3/e2fsck'
make[5]: *** [Makefile:404: all-progs-recursive] Error 1
make[5]: Leaving directory '/home/leopold/source/build_dir/host/e2fsprogs-1.43.3'
make[4]: *** [Makefile:340: all] Error 2
make[4]: Leaving directory '/home/leopold/source/build_dir/host/e2fsprogs-1.43.3'
make[3]: *** [Makefile:50: /home/leopold/source/build_dir/host/e2fsprogs-1.43.3/.built] Error 2
make[3]: Leaving directory '/home/leopold/source/tools/e2fsprogs'
make[2]: *** [tools/Makefile:148: tools/e2fsprogs/compile] Error 2
make[2]: Leaving directory '/home/leopold/source'
make[1]: *** [tools/Makefile:145: /home/leopold/source/staging_dir/target-mips_24kc_musl-1.1.16/stamp/.tools_install_yynyyyyynyyyyynyynnyyyyyyyyyyyyyyyyyyyynyynynyyyynnny] Error 2
make[1]: Leaving directory '/home/leopold/source'
make: *** [/home/leopold/source/include/toplevel.mk:207: world] Error 2

For my system package sys-fs/e2fsprogs-1.44.2 (older btw) compiled without any problem.
Please, help where I need to dig and may be you need additional info

PS Already found at forum : Building last 17.01 on w8970
It was bumped in older versions. Please can You update git source for openwrt-sdk-ar71xx?

1 Like

I found also that alot of packages are outdated a bit. For example, dropbear. Also I want to try compile with latest GCC (8.1.0) and binutils. Can You please inform me where I can change package versions locally for latest?

Checked last git source (without command git checkout lede-17.01)
Compiled OK with the same system environment. Seems fixed. Thanks!

You may wish to make a request:

or

https://bugs.lede-project.org/

The current master is past the 17.01.4 landmark, that's likely why it worked. If you compile with 17.01, the packages may be old.